# CVE-2024-48948: Valid ECDSA signatures erroneously rejected in Elliptic

> Attackers can cause denial of service by triggering signature verification failures in the Elliptic Node.js library due to a truncation anomaly.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2024
- **Updated:** 25 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-48948, GHSA-fc9h-whq2-v747, ROOT-APP-NPM-CVE-2024-48948, UBUNTU-CVE-2024-48948, openSUSE-SU-2024:14433-1

## What is CVE-2024-48948?

CVE-2024-48948 is a medium-severity vulnerability in n/a, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Elliptic package 6.5.7 for Node.js, in its for ECDSA implementation, does not correctly verify valid signatures if the hash contains at least four leading 0 bytes and when the order of the elliptic curve's base point is smaller than the hash, because of an _truncateToN anomaly. This leads to valid signatures being rejected. Legitimate transactions or communications may be incorrectly flagged as invalid.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-48948?

2 open source packages ship an affected version, including elliptic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elliptic` | npm | All versions | 6.6.0 |
| `elliptic` | npm | All versions | 6.6.0 |
| `python-pytest-html` | openSUSE:Tumbleweed | All versions | 4.1.1-3.1 |

Products: Indutny Elliptic.

## How do I fix CVE-2024-48948?

Upgrade elliptic to 6.6.0 or later.

## Is CVE-2024-48948 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48948 exists.

## Other vulnerabilities in n/a

- [CVE-2024-48949](https://insights.sbomify.com/CVE-2024-48949/): Elliptic's verify function omits uniqueness validation (critical 9.1)
- [CVE-2020-13822](https://insights.sbomify.com/CVE-2020-13822/): Signature Malleabillity in elliptic (high 7.7)
- [CVE-2020-28498](https://insights.sbomify.com/CVE-2020-28498/): Cryptographic Issues (medium 6.8)
- [CVE-2024-42459](https://insights.sbomify.com/CVE-2024-42459/): Elliptic's EDDSA missing signature length check (medium 5.3)
- [CVE-2024-42460](https://insights.sbomify.com/CVE-2024-42460/): Elliptic's ECDSA missing check for whether leading bit of r and s is zero (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48948 and fix it if it is affected.

What it is: CVE-2024-48948 is a medium-severity vulnerability in n/a, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-48948 exists.

Affected packages and fixed versions:
- elliptic (npm): affected all versions; fixed in 6.6.0
- elliptic (npm): affected all versions; fixed in 6.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48948/ (Markdown: https://insights.sbomify.com/CVE-2024-48948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48948
- OSV: https://osv.dev/vulnerability/CVE-2024-48948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48948/
Summaries are generated and may contain mistakes; the official description above is the record.
