# CVE-2024-48949: Elliptic's verify function omits uniqueness validation

> The Elliptic library fails to validate signature components, allowing attackers to bypass cryptographic verification checks.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 25 Nov 2025
- **Also known as:** AZL-50322, DEBIAN-CVE-2024-48949, GHSA-434g-2637-qmqr, RHSA-2024:8351, RHSA-2024:8507, UBUNTU-CVE-2024-48949, openSUSE-SU-2024:14403-1

## What is CVE-2024-48949?

CVE-2024-48949 is a critical vulnerability in n/a, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The verify function in lib/elliptic/eddsa/index.js in the Elliptic package before 6.5.6 for Node.js omits "sig.S().gte(sig.eddsa.curve.n) || sig.S().isNeg()" validation.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-48949?

2 open source packages ship an affected version, including elliptic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elliptic` | npm | All versions | 6.5.6 |
| `elliptic` | npm | All versions | 6.5.6 |
| `grafana` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-azure-monitor` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-cloudwatch` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-elasticsearch` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-graphite` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-influxdb` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-loki` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-mssql` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-mysql` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-opentsdb` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-postgres` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-prometheus` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana-stackdriver` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.3.6-6.el8_2 |
| `grafana` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:7.3.6-8.el8_4 |
| `grafana-debuginfo` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:7.3.6-8.el8_4 |
| `grafana` | Red Hat:rhel_e4s:8.4::appstream | All versions | 0:7.3.6-8.el8_4 |
| `grafana-debuginfo` | Red Hat:rhel_e4s:8.4::appstream | All versions | 0:7.3.6-8.el8_4 |
| `grafana` | Red Hat:rhel_tus:8.4::appstream | All versions | 0:7.3.6-8.el8_4 |
| `grafana-debuginfo` | Red Hat:rhel_tus:8.4::appstream | All versions | 0:7.3.6-8.el8_4 |
| `python-pytest-html` | openSUSE:Tumbleweed | All versions | 4.1.1-2.1 |

Products: Indutny Elliptic.

## How do I fix CVE-2024-48949?

Upgrade elliptic to 6.5.6 or later.

## Is CVE-2024-48949 being exploited?

There is no known exploitation of CVE-2024-48949 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-13822](https://insights.sbomify.com/CVE-2020-13822/): Signature Malleabillity in elliptic (high 7.7)
- [CVE-2020-28498](https://insights.sbomify.com/CVE-2020-28498/): Cryptographic Issues (medium 6.8)
- [CVE-2024-42459](https://insights.sbomify.com/CVE-2024-42459/): Elliptic's EDDSA missing signature length check (medium 5.3)
- [CVE-2024-42460](https://insights.sbomify.com/CVE-2024-42460/): Elliptic's ECDSA missing check for whether leading bit of r and s is zero (medium 5.3)
- [CVE-2024-48948](https://insights.sbomify.com/CVE-2024-48948/): Valid ECDSA signatures erroneously rejected in Elliptic (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-48949 and fix it if it is affected.

What it is: CVE-2024-48949 is a critical vulnerability in n/a, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-48949 in the wild and no public exploit code.

Affected packages and fixed versions:
- elliptic (npm): affected all versions; fixed in 6.5.6
- elliptic (npm): affected all versions; fixed in 6.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-48949/ (Markdown: https://insights.sbomify.com/CVE-2024-48949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-48949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-48949
- OSV: https://osv.dev/vulnerability/CVE-2024-48949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-48949/
Summaries are generated and may contain mistakes; the official description above is the record.
