{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-48957 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-48957 is a high-severity memory corruption vulnerability in Libarchive Libarchive, published on 10 Oct 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-48957 and fix it if it is affected.\n\nWhat it is: CVE-2024-48957 is a high-severity memory corruption vulnerability in Libarchive Libarchive, published on 10 Oct 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-48957 in the wild and no public exploit code.\n\nAffected product: Libarchive Libarchive. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48957/ (Markdown: https://insights.sbomify.com/CVE-2024-48957/index.md)","id":"CVE-2024-48957","markdown":"https://insights.sbomify.com/CVE-2024-48957/index.md","name":"CVE-2024-48957","record":{"aliases":["ALPINE-CVE-2024-48957","AZL-50307","AZL-50315","BELL-CVE-2024-48957","DEBIAN-CVE-2024-48957","GHSA-rmj4-vvpv-4m33","JLSEC-2025-240","SUSE-SU-2024:3675-1","UBUNTU-CVE-2024-48957"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"libarchive library","requires_auth":"none","summary":"An out-of-bounds access vulnerability in libarchive allows attackers to execute code or cause denial of service via crafted archive files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libarchive","vendor":"libarchive"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"execute_filter_audio in archive_read_support_format_rar.c in libarchive before 3.7.5 allows out-of-bounds access via a crafted archive file because src can move beyond dst.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP6","SUSE:Linux Enterprise Module for Development Tools 15 SP6","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2024-48957","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"libarchive:libarchive","products":["libarchive:libarchive"],"type":"memory_corruption","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2024-48958"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["3.7.2-150600.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/suse/libarchive\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2024:3675-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Development Tools 15 SP6","fixed":["3.7.2-150600.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/suse/libarchive\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Development%20Tools%2015%20SP6","source":"SUSE-SU-2024:3675-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.7.2-150600.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/opensuse/libarchive\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:3675-1"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2024-48956"},"products":["n/a"],"published":"2024-10-10","related":[{"cvss_score":9.1,"headline":"Memory corruption in n/a","id":"CVE-2024-37407","kev_date_added":null,"published":"2024-06-08"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2016-1541","kev_date_added":null,"published":"2016-05-07"},{"cvss_score":8.6,"headline":"Integer overflow in n/a","id":"CVE-2016-6250","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":7.8,"headline":"Libarchive: double free at archive_read_format_rar_seek_data() in archive_read_support_format_rar.c","id":"CVE-2025-5914","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2024-48958","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":7.8,"headline":"Integer overflow in n/a","id":"CVE-2016-4300","kev_date_added":null,"published":"2016-09-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-29","vendors":["n/a"]},"summary":"An out-of-bounds access vulnerability in libarchive allows attackers to execute code or cause denial of service via crafted archive files.","url":"https://insights.sbomify.com/CVE-2024-48957/"}