CVE-2024-48963 OS Command Injection in Snyk php plugin

High 7.5 Published Updated

Attackers can execute arbitrary code by tricking users into scanning malicious PHP projects with Snyk CLI.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-48963?

CVE-2024-48963 is a high-severity code injection vulnerability in Snyk Cli, published on 23 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted PHP project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.

Weakness: CWE-78

Which versions are affected by CVE-2024-48963?

2 open source packages ship an affected version, including snyk-php-plugin. It affects 1 product.

PackageAffectedFixed in
snyk-php-plugin npmAll versions1.10.0
snyk-php-plugin npmAll versions1.10.0

Products include Snyk Snyk Cli.

How do I fix CVE-2024-48963?

Upgrade snyk-php-plugin to 1.10.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-48963 being exploited?

There is no known exploitation of CVE-2024-48963 in the wild and no public exploit code.

Sources

Also known as GHSA-69f9-h8f9-7vjf.

Is CVE-2024-48963 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free