{"answers":{"affected":"2 open source packages ship an affected version, including snyk-php-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-48963 in the wild and no public exploit code.","fix":"Upgrade snyk-php-plugin to 1.10.0 or later.","what":"CVE-2024-48963 is a high-severity code injection vulnerability in Snyk Cli, published on 23 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-48963 and fix it if it is affected.\n\nWhat it is: CVE-2024-48963 is a high-severity code injection vulnerability in Snyk Cli, published on 23 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-48963 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snyk-php-plugin (npm): affected all versions; fixed in 1.10.0\n- snyk-php-plugin (npm): affected all versions; fixed in 1.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-48963/ (Markdown: https://insights.sbomify.com/CVE-2024-48963/index.md)","id":"CVE-2024-48963","markdown":"https://insights.sbomify.com/CVE-2024-48963/index.md","name":"CVE-2024-48963","record":{"aliases":["GHSA-69f9-h8f9-7vjf"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Snyk CLI","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into scanning malicious PHP projects with Snyk CLI.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"snyk_cli","vendor":"snyk"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted PHP project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS Command Injection in Snyk php plugin","id":"CVE-2024-48963","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"OS Command Injection in Snyk gradle plugin","id":"CVE-2024-48964"},"packages":[{"ecosystem":"npm","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"snyk-php-plugin","purl":null,"source":"GHSA-69f9-h8f9-7vjf"},{"ecosystem":"npm","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"snyk-php-plugin","purl":"pkg:npm/snyk-php-plugin","source":"GHSA-69f9-h8f9-7vjf"}],"prev":{"headline":"Apache OFBiz: Bypass SameSite restrictions with target redirection using URL parameters (SSTI and CSRF leading to RCE)","id":"CVE-2024-48962"},"products":["Snyk Cli","Snyk PHP Plugin"],"published":"2024-10-23","related":[{"cvss_score":7.5,"headline":"OS Command Injection in Snyk gradle plugin","id":"CVE-2024-48964","kev_date_added":null,"published":"2024-10-23"},{"cvss_score":5.8,"headline":"Code Injection","id":"CVE-2022-24441","kev_date_added":null,"published":"2022-11-30"},{"cvss_score":5,"headline":"Command Injection","id":"CVE-2022-22984","kev_date_added":null,"published":"2022-11-30"},{"cvss_score":2.4,"headline":"Snyk CLI Insertion of Sensitive Information into Log File allowed in DEBUG or DEBUG/TRACE mode","id":"CVE-2025-6624","kev_date_added":null,"published":"2025-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-24","vendors":["Snyk"]},"summary":"Attackers can execute arbitrary code by tricking users into scanning malicious PHP projects with Snyk CLI.","url":"https://insights.sbomify.com/CVE-2024-48963/"}