CVE-2024-48964 OS Command Injection in Snyk gradle plugin

High 7.5 Published Updated

Attackers can execute arbitrary code by tricking users into scanning malicious Gradle projects with Snyk CLI.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-48964?

CVE-2024-48964 is a high-severity code injection vulnerability in Snyk Cli, published on 23 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.

Weakness: CWE-94, CWE-78

Which versions are affected by CVE-2024-48964?

2 open source packages ship an affected version, including snyk-gradle-plugin. It affects 1 product.

PackageAffectedFixed in
snyk-gradle-plugin npmAll versions4.5.0
snyk-gradle-plugin npmAll versions4.5.0

Products include Snyk Snyk Cli.

How do I fix CVE-2024-48964?

Upgrade snyk-gradle-plugin to 4.5.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-48964 being exploited?

There is no known exploitation of CVE-2024-48964 in the wild and no public exploit code.

Sources

Also known as GHSA-qqqw-gm93-qf6m.

Is CVE-2024-48964 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free