# CVE-2024-49194: Databricks JDBC Driver Command Injection vulnerability

> An attacker can achieve remote code execution by tricking a victim into using a crafted JDBC connection URL with a malicious krbJAASFile parameter.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2024
- **Updated:** 2 Jul 2025
- **Also known as:** GHSA-jxw2-jvxf-5vrp

## What is CVE-2024-49194?

CVE-2024-49194 is a high-severity code injection vulnerability in n/a, published on 17 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Databricks JDBC Driver 2.x before 2.6.40 could potentially allow remote code execution (RCE) by triggering a JNDI injection via a JDBC URL parameter. The vulnerability is rooted in the improper handling of the krbJAASFile parameter. An attacker could potentially exploit this vulnerability to achieve Remote Code Execution in the context of the driver by tricking a victim into using a crafted connection URL that uses the property krbJAASFile.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-49194?

2 open source packages ship an affected version, including com.databricks:databricks-jdbc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.databricks:databricks-jdbc` | Maven | From 2.0 | 2.6.40 |
| `com.databricks:databricks-jdbc` | Maven | From 2.0 | 2.6.40 |

## How do I fix CVE-2024-49194?

Upgrade com.databricks:databricks-jdbc to 2.6.40 or later.

## Is CVE-2024-49194 being exploited?

There is no known exploitation of CVE-2024-49194 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49194 and fix it if it is affected.

What it is: CVE-2024-49194 is a high-severity code injection vulnerability in n/a, published on 17 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-49194 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.databricks:databricks-jdbc (Maven): affected from 2.0; fixed in 2.6.40
- com.databricks:databricks-jdbc (Maven): affected from 2.0; fixed in 2.6.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49194/ (Markdown: https://insights.sbomify.com/CVE-2024-49194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49194
- OSV: https://osv.dev/vulnerability/CVE-2024-49194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49194/
Summaries are generated and may contain mistakes; the official description above is the record.
