{"answers":{"affected":"12 open source packages ship an affected version, including io.github.openfeign.querydsl:querydsl-apt, com.querydsl:querydsl-apt and com.querydsl:querydsl-jpa.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49203 exists.","fix":"Upgrade io.github.openfeign.querydsl:querydsl-apt to a fixed version for your release line: 5.6.1 or 6.10.1.","what":"CVE-2024-49203 is a SQL injection vulnerability in n/a, published on 20 Nov 2024. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-49203 and fix it if it is affected.\n\nWhat it is: CVE-2024-49203 is a SQL injection vulnerability in n/a, published on 20 Nov 2024. It can be exploited over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49203 exists.\n\nAffected packages and fixed versions:\n- io.github.openfeign.querydsl:querydsl-apt (Maven): affected all versions; fixed in 5.6.1\n- io.github.openfeign.querydsl:querydsl-apt (Maven): affected all versions; fixed in 5.6.1\n- io.github.openfeign.querydsl:querydsl-apt (Maven): affected from 6.0.0.M1; fixed in 6.10.1\n- io.github.openfeign.querydsl:querydsl-apt (Maven): affected from 6.0.0.M1; fixed in 6.10.1\n- com.querydsl:querydsl-apt (Maven): affected all versions up to 5.1.0; no fix listed\n- com.querydsl:querydsl-apt (Maven): affected all versions up to 5.1.0; no fix listed\n- com.querydsl:querydsl-jpa (Maven): affected all versions up to 5.1.0; no fix listed\n- com.querydsl:querydsl-jpa (Maven): affected all versions up to 5.1.0; no fix listed\n- io.github.openfeign.querydsl:querydsl-jpa (Maven): affected all versions; fixed in 5.6.1\n- io.github.openfeign.querydsl:querydsl-jpa (Maven): affected all versions; fixed in 5.6.1\n- io.github.openfeign.querydsl:querydsl-jpa (Maven): affected from 6.0.0.M1; fixed in 6.10.1\n- io.github.openfeign.querydsl:querydsl-jpa (Maven): affected from 6.0.0.M1; fixed in 6.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-49203/ (Markdown: https://insights.sbomify.com/CVE-2024-49203/index.md)","id":"CVE-2024-49203","markdown":"https://insights.sbomify.com/CVE-2024-49203/index.md","name":"CVE-2024-49203","record":{"aliases":["CLSA-2025-1759277170","GHSA-6q3q-6v5j-h6vg","ROOT-APP-MAVEN-CVE-2024-49203"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Java query library","requires_auth":"unknown","summary":"SQL/HQL injection in Querydsl orderBy allows attackers to manipulate database queries if developers use untrusted input directly.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Querydsl 5.1.0 and OpenFeign Querydsl 6.8 allows SQL/HQL injection in orderBy in JPAQuery. NOTE: this is disputed by a Querydsl community member because the product is not intended to defend against a developer who uses untrusted input directly in query construction.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Querydsl vulnerable to HQL injection through orderBy","id":"CVE-2024-49203","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":12,"n_references":10,"next":{"headline":"Missing authorization in n/a","id":"CVE-2024-49208"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["5.1.0"],"package":"com.querydsl:querydsl-apt","purl":null,"source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["5.1.0"],"package":"com.querydsl:querydsl-apt","purl":"pkg:maven/com.querydsl/querydsl-apt","source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["5.1.0"],"package":"com.querydsl:querydsl-jpa","purl":null,"source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["5.1.0"],"package":"com.querydsl:querydsl-jpa","purl":"pkg:maven/com.querydsl/querydsl-jpa","source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["5.6.1"],"introduced":["0"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-apt","purl":null,"source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["5.6.1"],"introduced":["0"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-apt","purl":"pkg:maven/io.github.openfeign.querydsl/querydsl-apt","source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["6.10.1"],"introduced":["6.0.0.M1"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-apt","purl":null,"source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["6.10.1"],"introduced":["6.0.0.M1"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-apt","purl":"pkg:maven/io.github.openfeign.querydsl/querydsl-apt","source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["5.6.1"],"introduced":["0"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-jpa","purl":null,"source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["5.6.1"],"introduced":["0"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-jpa","purl":"pkg:maven/io.github.openfeign.querydsl/querydsl-jpa","source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["6.10.1"],"introduced":["6.0.0.M1"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-jpa","purl":null,"source":"GHSA-6q3q-6v5j-h6vg"},{"ecosystem":"Maven","fixed":["6.10.1"],"introduced":["6.0.0.M1"],"last_affected":[],"package":"io.github.openfeign.querydsl:querydsl-jpa","purl":"pkg:maven/io.github.openfeign.querydsl/querydsl-jpa","source":"GHSA-6q3q-6v5j-h6vg"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2024-49202"},"products":["n/a"],"published":"2024-11-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-21","vendors":["n/a"]},"summary":"SQL/HQL injection in Querydsl orderBy allows attackers to manipulate database queries if developers use untrusted input directly.","url":"https://insights.sbomify.com/CVE-2024-49203/"}