CVE-2024-49214 Security feature bypass in n/a
Attackers can bypass IP allow/block lists in HAProxy QUIC by spoofing IP addresses during 0-RTT session establishment.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-49214?
CVE-2024-49214 is a medium-severity vulnerability in n/a, published on 14 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
QUIC in HAProxy 3.1.x before 3.1-dev7, 3.0.x before 3.0.5, and 2.9.x before 2.9.11 allows opening a 0-RTT session with a spoofed IP address. This can bypass the IP allow/block list functionality.
Weakness: CWE-290
Which versions are affected by CVE-2024-49214?
1 open source package ship an affected version, including haproxy.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | All versions | 2.9.11, 3.0.5 |
Linux distribution packages (1)
haproxy openSUSE:Tumbleweed | All versions | 3.0.5+git0.8e879a52e-2.1 |
How do I fix CVE-2024-49214?
Upgrade haproxy to a fixed version for your release line: 2.9.11 or 3.0.5.
Is CVE-2024-49214 being exploited?
There is no known exploitation of CVE-2024-49214 in the wild and no public exploit code.
Sources
Also known as AZL-50333, BIT-haproxy-2024-49214, DEBIAN-CVE-2024-49214, GHSA-8jgf-8r3g-hxh8, MINI-3hxp-ppm3-c5mv, MINI-859q-6gfh-j7xc and 3 more.