# CVE-2024-49362: Remote Code Execution on click of <a> Link in markdown preview

> Attackers can execute arbitrary shell commands by tricking users into clicking malicious links in Joplin's markdown preview.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-hff8-hjwv-j9q7

## What is CVE-2024-49362?

CVE-2024-49362 is a high-severity code injection vulnerability in laurent22 joplin, published on 14 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Joplin is a free, open source note taking and to-do application. Joplin-desktop has a vulnerability that leads to remote code execution (RCE) when a user clicks on an <a> link within untrusted notes. The issue arises due to insufficient sanitization of <a> tag attributes introduced by the Mermaid. This vulnerability allows the execution of untrusted HTML content within the Electron window, which has full access to Node.js APIs, enabling arbitrary shell command execution.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-49362?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | From 3.0.0 | 3.1.0 |
| `joplin` | npm | From 3.0.0 | 3.1.0 |

Products: Joplin Project Joplin.

## How do I fix CVE-2024-49362?

Upgrade joplin to 3.1.0 or later.

## Is CVE-2024-49362 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49362 exists.

## Other vulnerabilities in laurent22 joplin

- [CVE-2022-23340](https://insights.sbomify.com/CVE-2022-23340/): Joplin Vulnerable to Code Injection (critical 9.8)
- [CVE-2024-40643](https://insights.sbomify.com/CVE-2024-40643/): Joplin has a parsing error leading to Cross-site Scripting (XSS) (critical 9.7)
- [CVE-2023-45673](https://insights.sbomify.com/CVE-2023-45673/): Arbitrary code execution on click of PDF links in Joplin (high 8.9)
- [CVE-2025-27134](https://insights.sbomify.com/CVE-2025-27134/): Privilege escalation in Joplin server via user patch endpoint (high 8.8)
- [CVE-2023-37898](https://insights.sbomify.com/CVE-2023-37898/): Safe mode Cross-site Scripting (XSS) vulnerability in Joplin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49362 and fix it if it is affected.

What it is: CVE-2024-49362 is a high-severity code injection vulnerability in laurent22 joplin, published on 14 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49362 exists.

Affected packages and fixed versions:
- joplin (npm): affected from 3.0.0; fixed in 3.1.0
- joplin (npm): affected from 3.0.0; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49362/ (Markdown: https://insights.sbomify.com/CVE-2024-49362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49362
- OSV: https://osv.dev/vulnerability/CVE-2024-49362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49362/
Summaries are generated and may contain mistakes; the official description above is the record.
