# CVE-2024-49364: tiny-secp256k1 vulnerable to private key extraction when signing a malicious JSON-stringifyable message in bundled environment

> Attackers can extract private keys by signing malicious messages in environments using the NPM buffer package, affecting users of tiny-secp256k1.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2025
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-7mc2-6phr-23xc

## What is CVE-2024-49364?

CVE-2024-49364 is a high-severity vulnerability in bitcoinjs tiny-secp256k1, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a private key can be extracted on signing a malicious JSON-stringifiable object, when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. The Buffer.isBuffer check can be bypassed, resulting in k reuse for different messages, leading to private key extraction over a single invalid message (and a second one for which any message/signature could be taken, e.g. previously known valid one). This issue has been patched in version 1.1.7.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2024-49364?

2 open source packages ship an affected version, including tiny-secp256k1.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tiny-secp256k1` | npm | All versions | 1.1.7 |
| `tiny-secp256k1` | npm | All versions | 1.1.7 |

## How do I fix CVE-2024-49364?

Upgrade tiny-secp256k1 to 1.1.7 or later.

## Is CVE-2024-49364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49364 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49364 and fix it if it is affected.

What it is: CVE-2024-49364 is a high-severity vulnerability in bitcoinjs tiny-secp256k1, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49364 exists.

Affected packages and fixed versions:
- tiny-secp256k1 (npm): affected all versions; fixed in 1.1.7
- tiny-secp256k1 (npm): affected all versions; fixed in 1.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49364/ (Markdown: https://insights.sbomify.com/CVE-2024-49364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49364
- OSV: https://osv.dev/vulnerability/CVE-2024-49364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49364/
Summaries are generated and may contain mistakes; the official description above is the record.
