{"answers":{"affected":"2 open source packages ship an affected version, including tiny-secp256k1.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49365 exists.","fix":"Upgrade tiny-secp256k1 to 1.1.7 or later.","what":"CVE-2024-49365 is a high-severity vulnerability in bitcoinjs tiny-secp256k1, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-49365 and fix it if it is affected.\n\nWhat it is: CVE-2024-49365 is a high-severity vulnerability in bitcoinjs tiny-secp256k1, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49365 exists.\n\nAffected packages and fixed versions:\n- tiny-secp256k1 (npm): affected all versions; fixed in 1.1.7\n- tiny-secp256k1 (npm): affected all versions; fixed in 1.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-49365/ (Markdown: https://insights.sbomify.com/CVE-2024-49365/index.md)","id":"CVE-2024-49365","markdown":"https://insights.sbomify.com/CVE-2024-49365/index.md","name":"CVE-2024-49365","record":{"aliases":["GHSA-5vhg-9xg4-cv9m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript crypto library","requires_auth":"none","summary":"Attackers can bypass signature verification in tiny-secp256k1 by exploiting a Buffer check flaw in specific bundled environments, leading to false-positive validation.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a malicious JSON-stringifyable message can be made passing on verify(), when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. Buffer.isBuffer check can be bypassed, resulting in strange objects being accepted as a message, and those messages could trick verify() into returning false-positive true values. This issue has been patched in version 1.1.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"tiny-secp256k1 allows for verify() bypass when running in bundled environment","id":"CVE-2024-49365","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Nginx UI's json field can construct a directory traversal payload, causing arbitrary files to be written","id":"CVE-2024-49366"},"packages":[{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"tiny-secp256k1","purl":null,"source":"GHSA-5vhg-9xg4-cv9m"},{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"tiny-secp256k1","purl":"pkg:npm/tiny-secp256k1","source":"GHSA-5vhg-9xg4-cv9m"}],"prev":{"headline":"tiny-secp256k1 vulnerable to private key extraction when signing a malicious JSON-stringifyable message in bundled environment","id":"CVE-2024-49364"},"products":["tiny-secp256k1"],"published":"2025-07-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-01","vendors":["bitcoinjs"]},"summary":"Attackers can bypass signature verification in tiny-secp256k1 by exploiting a Buffer check flaw in specific bundled environments, leading to false-positive validation.","url":"https://insights.sbomify.com/CVE-2024-49365/"}