# CVE-2024-49376: Autolab Has Misconfigured Reset Password Permissions

> Insufficiently privileged users can reset passwords for privileged accounts in Autolab, leading to account takeover.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2024
- **Updated:** 25 Oct 2024
- **Also known as:** GHSA-v46j-h43h-rwrm

## What is CVE-2024-49376?

CVE-2024-49376 is a high-severity missing authorization vulnerability in Autolab, published on 25 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Autolab, a course management service that enables auto-graded programming assignments, has misconfigured reset password permissions in version 3.0.0. For email-based accounts, users with insufficient privileges could reset and theoretically access privileged users' accounts by resetting their passwords. This issue is fixed in version 3.0.1. No known workarounds exist.

Weakness: CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-49376?

2 open source packages ship an affected version, including Autolab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Autolab` | RubyGems | From 3.0.0 | 3.0.1 |
| `Autolab` | RubyGems | From 3.0.0 | 3.0.1 |

Products: Autolabproject Autolab.

## How do I fix CVE-2024-49376?

Upgrade Autolab to 3.0.1 or later.

## Is CVE-2024-49376 being exploited?

There is no known exploitation of CVE-2024-49376 in the wild and no public exploit code.

## Other vulnerabilities in Autolab

- [CVE-2022-41955](https://insights.sbomify.com/CVE-2022-41955/): Autolab is vulnerable to remote code execution (RCE) via MOSS functionality (high 8.8)
- [CVE-2022-0936](https://insights.sbomify.com/CVE-2022-0936/): Cross-site Scripting (XSS) - Stored in autolab/autolab (high 7.6)
- [CVE-2024-53258](https://insights.sbomify.com/CVE-2024-53258/): download_all_submissions allows student to download another student's submissions in Autolab (high 7.1)
- [CVE-2024-53260](https://insights.sbomify.com/CVE-2024-53260/): Course Roster vulnerable to CSV Injection in Autolab (medium 6.8)
- [CVE-2023-32317](https://insights.sbomify.com/CVE-2023-32317/): Autolab tar slip in cheat checker functionality (`GHSL-2023-082`) (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49376 and fix it if it is affected.

What it is: CVE-2024-49376 is a high-severity missing authorization vulnerability in Autolab, published on 25 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-49376 in the wild and no public exploit code.

Affected packages and fixed versions:
- Autolab (RubyGems): affected from 3.0.0; fixed in 3.0.1
- Autolab (RubyGems): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49376/ (Markdown: https://insights.sbomify.com/CVE-2024-49376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49376
- OSV: https://osv.dev/vulnerability/CVE-2024-49376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49376/
Summaries are generated and may contain mistakes; the official description above is the record.
