CVE-2024-49377 Jinja2 Templates are vulnerable to XSS attacks due to their configuration in OctoPrint
Reflected XSS in OctoPrint allows attackers to steal or modify sensitive configuration settings and interrupt prints via crafted links.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-49377?
CVE-2024-49377 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 5 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain reflected XSS vulnerabilities in the login dialog and the standalone application key confirmation dialog. An attacker who successfully talked a victim into clicking on a specially crafted login link, or a malicious app running on a victim's computer triggering the application key workflow with specially crafted parameters and then redirecting the victim to the related standalone confirmation dialog could use this to retrieve or modify sensitive configuration settings, interrupt prints or otherwise interact with the OctoPrint instance in a malicious way. The above mentioned specific vulnerabilities of the login dialog and the standalone application key confirmation dialog have been patched in the bugfix release 1.10.3 by individual escaping of the detected locations. A global change throughout all of OctoPrint's templating system with the upcoming 1.11.0 release will handle this further, switching to globally enforced automatic escaping and thus reducing the attack surface in general. The latter will also improve the security of third party plugins. During a transition period, third party plugins will be able to opt into the automatic escaping. With OctoPrint 1.13.0, automatic escaping will be switched over to be enforced even for third party plugins, unless they explicitly opt-out.
Which versions are affected by CVE-2024-49377?
3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
octoprint PyPI | All versions | 1.10.3 |
octoprint PyPI | All versions | 1.10.3 |
OctoPrint PyPI | All versions | 1.10.3 |
Products include Octoprint Octoprint.
How do I fix CVE-2024-49377?
Upgrade octoprint to 1.10.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-49377 being exploited?
There is no known exploitation of CVE-2024-49377 in the wild and no public exploit code.
Other vulnerabilities in OctoPrint
- CVE-2018-16710 Information disclosure in n/a
- CVE-2025-58180 OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload
- CVE-2022-1430 Cross-site Scripting (XSS) - DOM in octoprint/octoprint
- CVE-2022-1432 Cross-site Scripting (XSS) - Generic in octoprint/octoprint
- CVE-2024-32977 OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled
Sources
Also known as GHSA-xvxq-g8hw-fx4g, PYSEC-2024-201.