# CVE-2024-49377: Jinja2 Templates are vulnerable to XSS attacks due to their configuration in OctoPrint

> Reflected XSS in OctoPrint allows attackers to steal or modify sensitive configuration settings and interrupt prints via crafted links.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Nov 2024
- **Updated:** 5 Nov 2024
- **Also known as:** GHSA-xvxq-g8hw-fx4g, PYSEC-2024-201

## What is CVE-2024-49377?

CVE-2024-49377 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 5 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain reflected XSS vulnerabilities in the login dialog and the standalone application key confirmation dialog.  An attacker who successfully talked a victim into clicking on a specially crafted login link, or a malicious app running on a victim's computer triggering the application key workflow with specially crafted parameters and then redirecting the victim to the related standalone confirmation dialog could use this to retrieve or modify sensitive configuration settings, interrupt prints or otherwise interact with the OctoPrint instance in a malicious way. The above mentioned specific vulnerabilities of the login dialog and the standalone application key confirmation dialog have been patched in the bugfix release 1.10.3 by individual escaping of the detected locations. A global change throughout all of OctoPrint's templating system with the upcoming 1.11.0 release will handle this further, switching to globally enforced automatic escaping and thus reducing the attack surface in general. The latter will also improve the security of third party plugins. During a transition period, third party plugins will be able to opt into the automatic escaping. With OctoPrint 1.13.0, automatic escaping will be switched over to be enforced even for third party plugins, unless they explicitly opt-out.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-49377?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.10.3 |
| `octoprint` | PyPI | All versions | 1.10.3 |
| `OctoPrint` | PyPI | All versions | 1.10.3 |

Products: Octoprint Octoprint.

## How do I fix CVE-2024-49377?

Upgrade octoprint to 1.10.3 or later.

## Is CVE-2024-49377 being exploited?

There is no known exploitation of CVE-2024-49377 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49377 and fix it if it is affected.

What it is: CVE-2024-49377 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 5 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-49377 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.10.3
- octoprint (PyPI): affected all versions; fixed in 1.10.3
- OctoPrint (PyPI): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49377/ (Markdown: https://insights.sbomify.com/CVE-2024-49377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49377
- OSV: https://osv.dev/vulnerability/CVE-2024-49377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49377/
Summaries are generated and may contain mistakes; the official description above is the record.
