# CVE-2024-49380: Plenti arbitrary file write vulnerability

> An attacker can write arbitrary files via the /postLocal endpoint when a user serves their website, potentially leading to remote code execution.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2024
- **Updated:** 25 Oct 2024
- **Also known as:** GHSA-2p96-p7qh-4rgr, GO-2024-3213

## What is CVE-2024-49380?

CVE-2024-49380 is a high-severity path traversal vulnerability in plentico plenti, published on 25 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plenti, a static site generator, has an arbitrary file write vulnerability in versions prior to 0.7.2. The `/postLocal` endpoint is vulnerable to an arbitrary file write vulnerability when a plenti user serves their website. This issue may lead to Remote Code Execution. Version 0.7.2 fixes the vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-49380?

3 open source packages ship an affected version, including github.com/plentico/plenti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/plentico/plenti` | Go | All versions | 0.7.2 |
| `github.com/plentico/plenti` | Go | All versions | 0.7.2 |
| `github.com/plentico/plenti` | Go | All versions | 0.7.2 |

Products: Plenti Plenti.

## How do I fix CVE-2024-49380?

Upgrade github.com/plentico/plenti to 0.7.2 or later.

## Is CVE-2024-49380 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49380 exists.

Public exploit code:

- Plenti < v0.7.2 - OS Command Injection (nuclei): http/cves/2024/CVE-2024-49380.yaml

## Other vulnerabilities in plentico plenti

- [CVE-2025-26260](https://insights.sbomify.com/CVE-2025-26260/): Plenti - Code Injection - Denial of Services (high 8.8)
- [CVE-2024-49381](https://insights.sbomify.com/CVE-2024-49381/): Plenti arbitrary file deletion vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49380 and fix it if it is affected.

What it is: CVE-2024-49380 is a high-severity path traversal vulnerability in plentico plenti, published on 25 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49380 exists.

Affected packages and fixed versions:
- github.com/plentico/plenti (Go): affected all versions; fixed in 0.7.2
- github.com/plentico/plenti (Go): affected all versions; fixed in 0.7.2
- github.com/plentico/plenti (Go): affected all versions; fixed in 0.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49380/ (Markdown: https://insights.sbomify.com/CVE-2024-49380/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49380
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49380
- OSV: https://osv.dev/vulnerability/CVE-2024-49380

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49380/
Summaries are generated and may contain mistakes; the official description above is the record.
