# CVE-2024-4941: Local File Inclusion in JSON component in gradio-app/gradio

> An attacker can read arbitrary files on the server by exploiting a path traversal flaw in the JSON component's file handling logic.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-6v6g-j5fq-hpvw, PYSEC-2024-184

## What is CVE-2024-4941?

CVE-2024-4941 is a high-severity path traversal vulnerability in Gradio Project Gradio, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A local file inclusion vulnerability exists in the JSON component of gradio-app/gradio version 4.25. The vulnerability arises from improper input validation in the `postprocess()` function within `gradio/components/json_component.py`, where a user-controlled string is parsed as JSON. If the parsed JSON object contains a `path` key, the specified file is moved to a temporary directory, making it possible to retrieve it later via the `/file=..` endpoint. This issue is due to the `processing_utils.move_files_to_cache()` function traversing any object passed to it, looking for a dictionary with a `path` key, and then copying the specified file to a temporary directory. The vulnerability can be exploited by an attacker to read files on the remote system, posing a significant security risk.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-4941?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 4.31.3 |
| `gradio` | PyPI | All versions | 4.31.3 |
| `gradio` | PyPI | All versions | 4.31.4 |

Products: Gradio Project Gradio.

## How do I fix CVE-2024-4941?

Upgrade gradio to a fixed version for your release line: 4.31.3 or 4.31.4.

## Is CVE-2024-4941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4941 exists.

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4941 and fix it if it is affected.

What it is: CVE-2024-4941 is a high-severity path traversal vulnerability in Gradio Project Gradio, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4941 exists.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 4.31.3
- gradio (PyPI): affected all versions; fixed in 4.31.3
- gradio (PyPI): affected all versions; fixed in 4.31.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4941/ (Markdown: https://insights.sbomify.com/CVE-2024-4941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4941
- OSV: https://osv.dev/vulnerability/CVE-2024-4941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4941/
Summaries are generated and may contain mistakes; the official description above is the record.
