# CVE-2024-49750: Snowflake Connector for Python has sensitive data in logs

> Attackers with log access can view sensitive Duo passcodes and Azure SAS tokens if DEBUG logging is enabled in the Snowflake Python connector.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2024
- **Updated:** 25 Oct 2024
- **Also known as:** ECHO-10ab-2811-913a, GHSA-5vvg-pvhp-hv2m, MINI-wg37-j2v3-x2fq, PYSEC-2024-191

## What is CVE-2024-49750?

CVE-2024-49750 is a medium-severity vulnerability in snowflakedb snowflake-connector-python, published on 24 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Prior to version 3.12.3, when the logging level was set by the user to DEBUG, the Connector could have logged Duo passcodes (when specified via the `passcode` parameter) and Azure SAS tokens. Additionally, the SecretDetector logging formatter, if enabled, contained bugs which caused it to not fully redact JWT tokens and certain private key formats. Snowflake released version 3.12.3 of the Snowflake Connector for Python, which fixes the issue. In addition to upgrading, users should review their logs for any potentially sensitive information that may have been captured.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-49750?

3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-connector-python` | PyPI | All versions | 3.12.3 |
| `snowflake-connector-python` | PyPI | All versions | 3.12.3 |
| `snowflake-connector-python` | PyPI | All versions | 3.12.3 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2024-49750?

Upgrade snowflake-connector-python to 3.12.3 or later.

## Is CVE-2024-49750 being exploited?

There is no known exploitation of CVE-2024-49750 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-connector-python

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2023-34233](https://insights.sbomify.com/CVE-2023-34233/): Snowflake Python Connector vulnerable to Command Injection (high 7.3)
- [CVE-2025-24793](https://insights.sbomify.com/CVE-2025-24793/): Snowflake Connector for Python has an SQL Injection in write_pandas (high 7.0)
- [CVE-2025-24794](https://insights.sbomify.com/CVE-2025-24794/): The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49750 and fix it if it is affected.

What it is: CVE-2024-49750 is a medium-severity vulnerability in snowflakedb snowflake-connector-python, published on 24 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-49750 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-connector-python (PyPI): affected all versions; fixed in 3.12.3
- snowflake-connector-python (PyPI): affected all versions; fixed in 3.12.3
- snowflake-connector-python (PyPI): affected all versions; fixed in 3.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49750/ (Markdown: https://insights.sbomify.com/CVE-2024-49750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49750
- OSV: https://osv.dev/vulnerability/CVE-2024-49750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49750/
Summaries are generated and may contain mistakes; the official description above is the record.
