CVE-2024-49755 Duende IdentityServer has insufficient validation of DPoP cnf claim in Local APIs

Low 3.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-49755?

CVE-2024-49755 is a low-severity vulnerability in DuendeSoftware IdentityServer, published on 28 Oct 2024.

Official description

Duende IdentityServer is an OpenID Connect and OAuth 2.x framework for ASP.NET Core. IdentityServer's local API authentication handler performs insufficient validation of the cnf claim in DPoP access tokens. This allows an attacker to use leaked DPoP access tokens at local api endpoints even without possessing the private key for signing proof tokens. Note that this only impacts custom endpoints within an IdentityServer implementation that have explicitly used the LocalApiAuthenticationHandler for authentication. This vulnerability is patched in IdentityServer 7.0.8. Version 6.3 and below are unaffected, as they do not support DPoP in Local APIs.

Weakness: CWE-287

Which versions are affected by CVE-2024-49755?

2 open source packages ship an affected version, including Duende.IdentityServer.

PackageAffectedFixed in
Duende.IdentityServer NuGetFrom 7.0.07.0.8
Duende.IdentityServer NuGetFrom 7.0.07.0.8

How do I fix CVE-2024-49755?

Upgrade Duende.IdentityServer to 7.0.8 or later.

Is CVE-2024-49755 being exploited?

There is no known exploitation of CVE-2024-49755 in the wild and no public exploit code.

Sources

Also known as GHSA-v9xq-2mvm-x8xc.

Is CVE-2024-49755 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free