{"answers":{"affected":"2 open source packages ship an affected version, including Duende.IdentityServer.","exploited":"There is no known exploitation of CVE-2024-49755 in the wild and no public exploit code.","fix":"Upgrade Duende.IdentityServer to 7.0.8 or later.","what":"CVE-2024-49755 is a low-severity vulnerability in DuendeSoftware IdentityServer, published on 28 Oct 2024."},"fix_prompt":"Check this codebase for CVE-2024-49755 and fix it if it is affected.\n\nWhat it is: CVE-2024-49755 is a low-severity vulnerability in DuendeSoftware IdentityServer, published on 28 Oct 2024. \nExploitation: There is no known exploitation of CVE-2024-49755 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Duende.IdentityServer (NuGet): affected from 7.0.0; fixed in 7.0.8\n- Duende.IdentityServer (NuGet): affected from 7.0.0; fixed in 7.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-49755/ (Markdown: https://insights.sbomify.com/CVE-2024-49755/index.md)","id":"CVE-2024-49755","markdown":"https://insights.sbomify.com/CVE-2024-49755/index.md","name":"CVE-2024-49755","record":{"aliases":["GHSA-v9xq-2mvm-x8xc"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Duende IdentityServer is an OpenID Connect and OAuth 2.x framework for ASP.NET Core. IdentityServer's local API authentication handler performs insufficient validation of the cnf claim in DPoP access tokens. This allows an attacker to use leaked DPoP access tokens at local api endpoints even without possessing the private key for signing proof tokens. Note that this only impacts custom endpoints within an IdentityServer implementation that have explicitly used the LocalApiAuthenticationHandler for authentication. This vulnerability is patched in IdentityServer 7.0.8. Version 6.3 and below are unaffected, as they do not support DPoP in Local APIs.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Duende IdentityServer has insufficient validation of DPoP cnf claim in Local APIs","id":"CVE-2024-49755","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"AshPostgres empty, atomic, non-bulk actions, policy bypass for side-effects vulnerability.","id":"CVE-2024-49756"},"packages":[{"ecosystem":"NuGet","fixed":["7.0.8"],"introduced":["7.0.0"],"last_affected":[],"package":"Duende.IdentityServer","purl":null,"source":"GHSA-v9xq-2mvm-x8xc"},{"ecosystem":"NuGet","fixed":["7.0.8"],"introduced":["7.0.0"],"last_affected":[],"package":"Duende.IdentityServer","purl":"pkg:nuget/Duende.IdentityServer","source":"GHSA-v9xq-2mvm-x8xc"}],"prev":{"headline":"LibreNMS has a stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/api-access.inc.php","id":"CVE-2024-49754"},"products":["IdentityServer"],"published":"2024-10-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-29","vendors":["DuendeSoftware"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-49755/"}