# CVE-2024-49755: Duende IdentityServer has insufficient validation of DPoP cnf claim in Local APIs


- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2024
- **Updated:** 29 Oct 2024
- **Also known as:** GHSA-v9xq-2mvm-x8xc

## What is CVE-2024-49755?

CVE-2024-49755 is a low-severity vulnerability in DuendeSoftware IdentityServer, published on 28 Oct 2024. 

### Official description

Duende IdentityServer is an OpenID Connect and OAuth 2.x framework for ASP.NET Core. IdentityServer's local API authentication handler performs insufficient validation of the cnf claim in DPoP access tokens. This allows an attacker to use leaked DPoP access tokens at local api endpoints even without possessing the private key for signing proof tokens. Note that this only impacts custom endpoints within an IdentityServer implementation that have explicitly used the LocalApiAuthenticationHandler for authentication. This vulnerability is patched in IdentityServer 7.0.8. Version 6.3 and below are unaffected, as they do not support DPoP in Local APIs.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-49755?

2 open source packages ship an affected version, including Duende.IdentityServer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Duende.IdentityServer` | NuGet | From 7.0.0 | 7.0.8 |
| `Duende.IdentityServer` | NuGet | From 7.0.0 | 7.0.8 |

## How do I fix CVE-2024-49755?

Upgrade Duende.IdentityServer to 7.0.8 or later.

## Is CVE-2024-49755 being exploited?

There is no known exploitation of CVE-2024-49755 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49755 and fix it if it is affected.

What it is: CVE-2024-49755 is a low-severity vulnerability in DuendeSoftware IdentityServer, published on 28 Oct 2024. 
Exploitation: There is no known exploitation of CVE-2024-49755 in the wild and no public exploit code.

Affected packages and fixed versions:
- Duende.IdentityServer (NuGet): affected from 7.0.0; fixed in 7.0.8
- Duende.IdentityServer (NuGet): affected from 7.0.0; fixed in 7.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49755/ (Markdown: https://insights.sbomify.com/CVE-2024-49755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49755
- OSV: https://osv.dev/vulnerability/CVE-2024-49755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49755/
Summaries are generated and may contain mistakes; the official description above is the record.
