# CVE-2024-49756: AshPostgres empty, atomic, non-bulk actions, policy bypass for side-effects vulnerability.

> Attackers can bypass authorization policies to trigger unintended side effects in specific AshPostgres update actions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2024
- **Updated:** 24 Oct 2024
- **Also known as:** GHSA-hf59-7rwq-785m

## What is CVE-2024-49756?

CVE-2024-49756 is a medium-severity missing authorization vulnerability in ash-project ash_postgres, published on 23 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AshPostgres is the PostgreSQL data layer for Ash Framework. Starting in version 2.0.0 and prior to version 2.4.10, in certain very specific situations, it was possible for the policies of an update action to be skipped. This occurred only on "empty" update actions (no changing fields), and would allow their hooks (side effects) to be performed when they should not have been. Note that this does not allow reading new data that the user should not have had access to, only triggering a side effect a user should not have been able to trigger.

To be vulnerable, an affected user must have an update action that is on a resource with no attributes containing an "update default" (updated_at timestamp, for example); can be performed atomically; does not have `require_atomic? false`; has at least one authorizer (typically `Ash.Policy.Authorizer`); and has at least one `change` (on the resource's `changes` block or in the action itself). This is where the side-effects would be performed when they should not have been.

This problem has been patched in `2.4.10` of `ash_postgres`. Several workarounds are available. Potentially affected users may determine that none of their actions are vulnerable using a script the maintainers provide in the GitHub Security Advisory, add `require_atomic? false` to any potentially affected update action, replace any usage of `Ash.update` with `Ash.bulk_update` for an affected action, and/or add an update timestamp to their action.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2024-49756?

2 open source packages ship an affected version, including ash_postgres.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_postgres` | Hex | From 2.0.0 | 2.4.10 |
| `ash_postgres` | Hex | From 2.0.0 | 2.4.10 |

## How do I fix CVE-2024-49756?

Upgrade ash_postgres to 2.4.10 or later.

## Is CVE-2024-49756 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49756 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49756 and fix it if it is affected.

What it is: CVE-2024-49756 is a medium-severity missing authorization vulnerability in ash-project ash_postgres, published on 23 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-49756 exists.

Affected packages and fixed versions:
- ash_postgres (Hex): affected from 2.0.0; fixed in 2.4.10
- ash_postgres (Hex): affected from 2.0.0; fixed in 2.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49756/ (Markdown: https://insights.sbomify.com/CVE-2024-49756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49756
- OSV: https://osv.dev/vulnerability/CVE-2024-49756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49756/
Summaries are generated and may contain mistakes; the official description above is the record.
