# CVE-2024-49767: Werkzeug possible resource exhaustion when parsing file data in forms

> Attackers can cause resource exhaustion and denial of service by sending crafted multipart form data to applications using the Werkzeug library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2024
- **Updated:** 20 May 2026
- **Also known as:** ALPINE-CVE-2024-49767, AZL-51690, AZL-51723, BELL-CVE-2024-49767, CLEANSTART-2026-PR62094, CLEANSTART-2026-QY47175, DEBIAN-CVE-2024-49767, ECHO-fdd1-b611-bd89, GHSA-q34m-jh98-gwm2, MGASA-2024-0351, MINI-2cxx-4gv7-x6xp, MINI-mjfp-jxq9-h4f3, OESA-2025-1424, OESA-2025-1425, OESA-2025-1426, PYSEC-2026-1860, PYSEC-2026-3417, ROOT-APP-PYPI-CVE-2024-49767, SUSE-SU-2024:3810-1, UBUNTU-CVE-2024-49767, USN-7093-1, openSUSE-SU-2024:14437-1

## What is CVE-2024-49767?

CVE-2024-49767 is a medium-severity denial of service vulnerability in pallets Quart, published on 25 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Werkzeug is a Web Server Gateway Interface web application library. Applications using `werkzeug.formparser.MultiPartParser` corresponding to a version of Werkzeug prior to 3.0.6 to parse `multipart/form-data` requests (e.g. all flask applications) are vulnerable to a relatively simple but effective resource exhaustion (denial of service) attack. A specifically crafted form submission request can cause the parser to allocate and block 3 to 8 times the upload size in main memory. There is no upper limit; a single upload at 1 Gbit/s can exhaust 32 GB of RAM in less than 60 seconds. Werkzeug version 3.0.6 fixes this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-49767?

6 open source packages ship an affected version, including quart, Quart and Werkzeug. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quart` | PyPI | All versions | 0.20.0 |
| `quart` | PyPI | All versions | 0.20.0 |
| `Quart` | PyPI | All versions | 0.20.0 |
| `Werkzeug` | PyPI | From 2.0.0rc1 | 3.0.6 |
| `werkzeug` | PyPI | From 2.0.0rc1 | 3.0.6 |
| `werkzeug` | PyPI | From 2.0.0rc1 | 3.0.6 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Python 3 15 SP5 | All versions | 2.3.6-150400.6.12.1 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 2.3.6-150400.6.12.1 |
| `python-Werkzeug` | openSUSE:Leap 15.5 | All versions | 2.3.6-150400.6.12.1 |
| `python-Werkzeug` | openSUSE:Leap 15.6 | All versions | 2.3.6-150400.6.12.1 |
| `python-Werkzeug` | openSUSE:Tumbleweed | All versions | 3.0.6-1.1 |

Products: Palletsprojects Quart, Palletsprojects Werkzeug.

## How do I fix CVE-2024-49767?

Upgrade quart to 0.20.0 or later.

## Is CVE-2024-49767 being exploited?

There is no known exploitation of CVE-2024-49767 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49767 and fix it if it is affected.

What it is: CVE-2024-49767 is a medium-severity denial of service vulnerability in pallets Quart, published on 25 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-49767 in the wild and no public exploit code.

Affected packages and fixed versions:
- quart (PyPI): affected all versions; fixed in 0.20.0
- quart (PyPI): affected all versions; fixed in 0.20.0
- Quart (PyPI): affected all versions; fixed in 0.20.0
- Werkzeug (PyPI): affected from 2.0.0rc1; fixed in 3.0.6
- werkzeug (PyPI): affected from 2.0.0rc1; fixed in 3.0.6
- werkzeug (PyPI): affected from 2.0.0rc1; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49767/ (Markdown: https://insights.sbomify.com/CVE-2024-49767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49767
- OSV: https://osv.dev/vulnerability/CVE-2024-49767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49767/
Summaries are generated and may contain mistakes; the official description above is the record.
