CVE-2024-49769 Waitress has a denial of service leading to high CPU usage/resource exhaustion

High 7.5 Published Updated

A remote attacker can cause high CPU usage and resource exhaustion in Waitress by closing connections prematurely, leading to a busy-loop.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-49769?

CVE-2024-49769 is a high-severity denial of service vulnerability in Pylons waitress, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Waitress is a Web Server Gateway Interface server for Python 2 and 3. When a remote client closes the connection before waitress has had the opportunity to call getpeername() waitress won't correctly clean up the connection leading to the main thread attempting to write to a socket that no longer exists, but not removing it from the list of sockets to attempt to process. This leads to a busy-loop calling the write function. A remote attacker could run waitress out of available sockets with very little resources required. Waitress 3.0.1 contains fixes that remove the race condition.

Weakness: CWE-772

Which versions are affected by CVE-2024-49769?

3 open source packages ship an affected version, including waitress. It affects 1 product.

PackageAffectedFixed in
waitress PyPIAll versions3.0.1
waitress PyPIAll versions3.0.1
waitress PyPIAll versions3.0.1
Linux distribution packages (20)
python-waitress SUSE:Enterprise Storage 7.1All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Module for Basesystem 15 SP5All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Module for Basesystem 15 SP6All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Module for Package Hub 15 SP6All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Server 15 SP2-LTSSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Server 15 SP3-LTSSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Server 15 SP4-LTSSAll versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Server for SAP Applications 15 SP2All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Server for SAP Applications 15 SP3All versions1.4.3-150000.3.9.1
python-waitress SUSE:Linux Enterprise Server for SAP Applications 15 SP4All versions1.4.3-150000.3.9.1
python-waitress SUSE:Manager Proxy 4.3All versions1.4.3-150000.3.9.1
python-waitress SUSE:Manager Server 4.3All versions1.4.3-150000.3.9.1
python-waitress openSUSE:Leap 15.5All versions1.4.3-150000.3.9.1
python-waitress openSUSE:TumbleweedAll versions3.0.1-1.1
python-waitress openSUSE:TumbleweedAll versions3.0.2-1.7

Products include Agendaless Waitress.

How do I fix CVE-2024-49769?

Upgrade waitress to 3.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-49769 being exploited?

There is no known exploitation of CVE-2024-49769 in the wild and no public exploit code.

Sources

Also known as AZL-51822, AZL-51831, CLSA-2025-1750810248, DEBIAN-CVE-2024-49769, DLA-3955-1, ECHO-283f-0619-628b and 11 more.

Is CVE-2024-49769 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free