# CVE-2024-49769: Waitress has a denial of service leading to high CPU usage/resource exhaustion

> A remote attacker can cause high CPU usage and resource exhaustion in Waitress by closing connections prematurely, leading to a busy-loop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2024
- **Updated:** 17 Nov 2024
- **Also known as:** AZL-51822, AZL-51831, CLSA-2025-1750810248, DEBIAN-CVE-2024-49769, DLA-3955-1, ECHO-283f-0619-628b, GHSA-3f84-rpwh-47g6, OESA-2024-2374, OESA-2024-2375, OESA-2024-2376, OESA-2024-2377, OESA-2025-1436, PYSEC-2024-211, SUSE-SU-2024:4107-1, UBUNTU-CVE-2024-49769, openSUSE-SU-2024:14445-1, openSUSE-SU-2026:12047-1

## What is CVE-2024-49769?

CVE-2024-49769 is a high-severity denial of service vulnerability in Pylons waitress, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Waitress is a Web Server Gateway Interface server for Python 2 and 3. When a remote client closes the connection before waitress has had the opportunity to call getpeername() waitress won't correctly clean up the connection leading to the main thread attempting to write to a socket that no longer exists, but not removing it from the list of sockets to attempt to process. This leads to a busy-loop calling the write function. A remote attacker could run waitress out of available sockets with very little resources required. Waitress 3.0.1 contains fixes that remove the race condition.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2024-49769?

3 open source packages ship an affected version, including waitress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `waitress` | PyPI | All versions | 3.0.1 |
| `waitress` | PyPI | All versions | 3.0.1 |
| `waitress` | PyPI | All versions | 3.0.1 |
| `python-waitress` | SUSE:Enterprise Storage 7.1 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Manager Proxy 4.3 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | SUSE:Manager Server 4.3 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | openSUSE:Leap 15.5 | All versions | 1.4.3-150000.3.9.1 |
| `python-waitress` | openSUSE:Tumbleweed | All versions | 3.0.1-1.1 |
| `python-waitress` | openSUSE:Tumbleweed | All versions | 3.0.2-1.7 |

Products: Agendaless Waitress.

## How do I fix CVE-2024-49769?

Upgrade waitress to 3.0.1 or later.

## Is CVE-2024-49769 being exploited?

There is no known exploitation of CVE-2024-49769 in the wild and no public exploit code.

## Other vulnerabilities in Pylons waitress

- [CVE-2024-49768](https://insights.sbomify.com/CVE-2024-49768/): Waitress has request processing race condition in HTTP pipelining with invalid first request (critical 9.1)
- [CVE-2022-24761](https://insights.sbomify.com/CVE-2022-24761/): HTTP Request Smuggling in waitress (high 7.5)
- [CVE-2019-16792](https://insights.sbomify.com/CVE-2019-16792/): HTTP Request Smuggling: Content-Length Sent Twice in Waitress (high 7.1)
- [CVE-2019-16789](https://insights.sbomify.com/CVE-2019-16789/): HTTP Request Smuggling in Waitress: Invalid whitespace characters in headers (high 7.1)
- [CVE-2019-16785](https://insights.sbomify.com/CVE-2019-16785/): HTTP Request Smuggling: LF vs CRLF handling in Waitress (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-49769 and fix it if it is affected.

What it is: CVE-2024-49769 is a high-severity denial of service vulnerability in Pylons waitress, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-49769 in the wild and no public exploit code.

Affected packages and fixed versions:
- waitress (PyPI): affected all versions; fixed in 3.0.1
- waitress (PyPI): affected all versions; fixed in 3.0.1
- waitress (PyPI): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-49769/ (Markdown: https://insights.sbomify.com/CVE-2024-49769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-49769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-49769
- OSV: https://osv.dev/vulnerability/CVE-2024-49769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-49769/
Summaries are generated and may contain mistakes; the official description above is the record.
