# CVE-2024-4990: Unsafe Reflection in base Component class in yiisoft/yii2

> Attackers can instantiate arbitrary classes via unsafe reflection in the base Component class, potentially leading to code execution or data theft.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-cjcc-p67m-7qxm

## What is CVE-2024-4990?

CVE-2024-4990 is a high-severity code injection vulnerability in yiisoft/yii2, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In yiisoft/yii2 version 2.0.48, the base Component class contains a vulnerability where the `__set()` magic method does not validate that the value passed is a valid Behavior class name or configuration. This allows an attacker to instantiate arbitrary classes, passing parameters to their constructors and invoking setter methods. Depending on the installed dependencies, various types of attacks are possible, including the execution of arbitrary code, retrieval of sensitive information, and unauthorized access.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2024-4990?

2 open source packages ship an affected version, including yiisoft/yii2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2` | Packagist | All versions | 2.0.49.4 |
| `yiisoft/yii2` | Packagist | All versions | 2.0.49.4 |

Products: Yiiframework Yii.

## How do I fix CVE-2024-4990?

Upgrade yiisoft/yii2 to 2.0.49.4 or later.

## Is CVE-2024-4990 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4990 exists.

## Other vulnerabilities in yiisoft/yii2

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2015-5467](https://insights.sbomify.com/CVE-2015-5467/): Yii2 allows attackers to execute any local .php file via a relative path in the view parameter (critical 9.8)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4990 and fix it if it is affected.

What it is: CVE-2024-4990 is a high-severity code injection vulnerability in yiisoft/yii2, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4990 exists.

Affected packages and fixed versions:
- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.49.4
- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.49.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4990/ (Markdown: https://insights.sbomify.com/CVE-2024-4990/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4990
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4990
- OSV: https://osv.dev/vulnerability/CVE-2024-4990

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4990/
Summaries are generated and may contain mistakes; the official description above is the record.
