CVE-2024-4994 Cross-Site Request Forgery (CSRF) in GitLab
Attackers can perform CSRF attacks on GitLab's GraphQL API to execute arbitrary mutations, potentially modifying data or executing code.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-4994?
CVE-2024-4994 is a high-severity vulnerability in Gitlab Gitlab, published on 20 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions from 16.1.0 before 16.11.5, all versions starting from 17.0 before 17.0.3, all versions starting from 17.1.0 before 17.1.1 which allowed for a CSRF attack on GitLab's GraphQL API leading to the execution of arbitrary GraphQL mutations.
Weakness: CWE-352
Which versions are affected by CVE-2024-4994?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.1.0 | 16.11.5, 17.1.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-4994?
Upgrade gitlab to a fixed version for your release line: 16.11.5 or 17.1.2.
Is CVE-2024-4994 being exploited?
There is no known exploitation of CVE-2024-4994 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-4994, GHSA-44j4-r7x2-mjhj, UBUNTU-CVE-2024-4994.