CVE-2024-5005 Incorrect Provision of Specified Functionality in GitLab

Medium 4.3 Published Updated

Guest users can disclose project templates via the API, exposing sensitive project data to unauthorized users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-5005?

CVE-2024-5005 is a medium-severity vulnerability in Gitlab Gitlab, published on 11 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered discovered in GitLab EE/CE affecting all versions starting from 11.4 before 17.2.9, all versions starting from 17.3 before 17.3.5, all versions starting from 17.4 before 17.4.2 It was possible for guest users to disclose project templates using the API.

Weakness: CWE-684

Which versions are affected by CVE-2024-5005?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.4.017.2.9, 17.3.5, 17.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-5005?

Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.

Is CVE-2024-5005 being exploited?

There is no known exploitation of CVE-2024-5005 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-5005, GHSA-58jq-vjfq-8v45, UBUNTU-CVE-2024-5005.

Is CVE-2024-5005 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free