# CVE-2024-5023: Arbitrary File Read Vulnerability in ConsoleMe via Limited Git command RCE

> Attackers can execute arbitrary commands via Git command injection in ConsoleMe, leading to remote code execution and arbitrary file reads.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-3783-62vc-jr7x, PYSEC-2026-318

## What is CVE-2024-5023?

CVE-2024-5023 is a critical command injection vulnerability in Netflix ConsoleMe, published on 16 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Netflix ConsoleMe allows Command Injection.This issue affects ConsoleMe: before 1.4.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-5023?

3 open source packages ship an affected version, including consoleme.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consoleme` | PyPI | All versions | 1.4.0 |
| `consoleme` | PyPI | All versions | 1.4.0 |
| `consoleme` | PyPI | All versions | 1.4.0 |

## How do I fix CVE-2024-5023?

Upgrade consoleme to 1.4.0 or later.

## Is CVE-2024-5023 being exploited?

There is no known exploitation of CVE-2024-5023 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5023 and fix it if it is affected.

What it is: CVE-2024-5023 is a critical command injection vulnerability in Netflix ConsoleMe, published on 16 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5023 in the wild and no public exploit code.

Affected packages and fixed versions:
- consoleme (PyPI): affected all versions; fixed in 1.4.0
- consoleme (PyPI): affected all versions; fixed in 1.4.0
- consoleme (PyPI): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5023/ (Markdown: https://insights.sbomify.com/CVE-2024-5023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5023
- OSV: https://osv.dev/vulnerability/CVE-2024-5023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5023/
Summaries are generated and may contain mistakes; the official description above is the record.
