CVE-2024-50336 matrix-js-sdk has insufficient MXC URI validation which allows client-side path traversal
A malicious room member can trigger clients using matrix-js-sdk to issue arbitrary authenticated GET requests to the homeserver via crafted MXC URIs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-50336?
CVE-2024-50336 is a medium-severity path traversal vulnerability in matrix-org matrix-js-sdk, published on 12 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
matrix-js-sdk is a Matrix messaging protocol Client-Server SDK for JavaScript. matrix-js-sdk before 34.11.0 is vulnerable to client-side path traversal via crafted MXC URIs. A malicious room member can trigger clients based on the matrix-js-sdk to issue arbitrary authenticated GET requests to the client's homeserver. Fixed in matrix-js-sdk 34.11.1.
Weakness: CWE-22
Which versions are affected by CVE-2024-50336?
2 open source packages ship an affected version, including matrix-js-sdk.
| Package | Affected | Fixed in |
|---|---|---|
matrix-js-sdk npm | All versions | 34.11.1 |
matrix-js-sdk npm | All versions | 34.11.1 |
Linux distribution packages (7)
MozillaThunderbird SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 128.5.2-150200.8.194.1 |
MozillaThunderbird SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 128.5.2-150200.8.194.1 |
MozillaThunderbird SUSE:Linux Enterprise Workstation Extension 15 SP5 | All versions | 128.5.2-150200.8.194.1 |
MozillaThunderbird SUSE:Linux Enterprise Workstation Extension 15 SP6 | All versions | 128.5.2-150200.8.194.1 |
MozillaThunderbird openSUSE:Leap 15.5 | All versions | 128.5.2-150200.8.194.1 |
MozillaThunderbird openSUSE:Leap 15.6 | All versions | 128.5.2-150200.8.194.1 |
MozillaThunderbird openSUSE:Tumbleweed | All versions | 128.5.2-1.1 |
How do I fix CVE-2024-50336?
Upgrade matrix-js-sdk to 34.11.1 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-50336 being exploited?
There is no known exploitation of CVE-2024-50336 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2024-50336, GHSA-xvg8-m4x3-w6xr, MGASA-2024-0395, SUSE-SU-2024:4326-1, UBUNTU-CVE-2024-50336, openSUSE-SU-2024:14584-1.