{"answers":{"affected":"2 open source packages ship an affected version, including git-credential-manager.","exploited":"There is no known exploitation of CVE-2024-50338 in the wild and no public exploit code.","fix":"Upgrade git-credential-manager to 2.6.1 or later.","what":"CVE-2024-50338 is a high-severity vulnerability in git-ecosystem git-credential-manager, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-50338 and fix it if it is affected.\n\nWhat it is: CVE-2024-50338 is a high-severity vulnerability in git-ecosystem git-credential-manager, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-50338 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git-credential-manager (NuGet): affected all versions; fixed in 2.6.1\n- git-credential-manager (NuGet): affected all versions; fixed in 2.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-50338/ (Markdown: https://insights.sbomify.com/CVE-2024-50338/index.md)","id":"CVE-2024-50338","markdown":"https://insights.sbomify.com/CVE-2024-50338/index.md","name":"CVE-2024-50338","record":{"aliases":["GHSA-86c2-4x57-wc8g"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Git Credential Manager","requires_auth":"none","summary":"An attacker can leak Git credentials by crafting a malicious remote URL exploiting newline parsing differences between Git and GCM.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Git Credential Manager (GCM) is a secure Git credential helper built on .NET that runs on Windows, macOS, and Linux. The Git credential protocol is text-based over standard input/output, and consists of a series of lines of key-value pairs in the format `key=value`. Git's documentation restricts the use of the NUL (`\\0`) character and newlines to form part of the keys or values. When Git reads from standard input, it considers both LF and CRLF as newline characters for the credential protocol by virtue of calling `strbuf_getline` that calls to `strbuf_getdelim_strip_crlf`. Git also validates that a newline is not present in the value by checking for the presence of the line-feed character (LF, `\\n`), and errors if this is the case. This captures both LF and CRLF-type newlines. Git Credential Manager uses the .NET standard library `StreamReader` class to read the standard input stream line-by-line and parse the `key=value` credential protocol format. The implementation of the `ReadLineAsync` method considers LF, CRLF, and CR as valid line endings. This is means that .NET considers a single CR as a valid newline character, whereas Git does not. This mismatch of newline treatment between Git and GCM means that an attacker can craft a malicious remote URL. When a user clones or otherwise interacts with a malicious repository that requires authentication, the attacker can capture credentials for another Git remote. The attack is also heightened when cloning from repositories with submodules when using the `--recursive` clone option as the user is not able to inspect the submodule remote URLs beforehand. This issue has been patched in version 2.6.1 and all users are advised to upgrade. Users unable to upgrade should only interact with trusted remote repositories, and not clone with `--recursive` to allow inspection of any submodule URLs before cloning those submodules.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Carriage-return character in remote URL allows malicious repository to leak credentials in Git Credential Manager","id":"CVE-2024-50338","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":8,"next":{"headline":"GLPI vulnerable to unauthenticated session hijacking","id":"CVE-2024-50339"},"packages":[{"ecosystem":"NuGet","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"git-credential-manager","purl":null,"source":"GHSA-86c2-4x57-wc8g"},{"ecosystem":"NuGet","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"git-credential-manager","purl":"pkg:nuget/git-credential-manager","source":"GHSA-86c2-4x57-wc8g"}],"prev":{"headline":"Chamilo: Potential unauthenticated blind SSRF via openid function","id":"CVE-2024-50337"},"products":["git-credential-manager"],"published":"2025-01-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["git-ecosystem"]},"summary":"An attacker can leak Git credentials by crafting a malicious remote URL exploiting newline parsing differences between Git and GCM.","url":"https://insights.sbomify.com/CVE-2024-50338/"}