# CVE-2024-50338: Carriage-return character in remote URL allows malicious repository to leak credentials in Git Credential Manager

> An attacker can leak Git credentials by crafting a malicious remote URL exploiting newline parsing differences between Git and GCM.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-86c2-4x57-wc8g

## What is CVE-2024-50338?

CVE-2024-50338 is a high-severity vulnerability in git-ecosystem git-credential-manager, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Git Credential Manager (GCM) is a secure Git credential helper built on .NET that runs on Windows, macOS, and Linux. The Git credential protocol is text-based over standard input/output, and consists of a series of lines of key-value pairs in the format `key=value`. Git's documentation restricts the use of the NUL (`\0`) character and newlines to form part of the keys or values. When Git reads from standard input, it considers both LF and CRLF as newline characters for the credential protocol by virtue of calling `strbuf_getline` that calls to `strbuf_getdelim_strip_crlf`. Git also validates that a newline is not present in the value by checking for the presence of the line-feed character (LF, `\n`), and errors if this is the case. This captures both LF and CRLF-type newlines. Git Credential Manager uses the .NET standard library `StreamReader` class to read the standard input stream line-by-line and parse the `key=value` credential protocol format. The implementation of the `ReadLineAsync` method considers LF, CRLF, and CR as valid line endings. This is means that .NET considers a single CR as a valid newline character, whereas Git does not. This mismatch of newline treatment between Git and GCM means that an attacker can craft a malicious remote URL. When a user clones or otherwise interacts with a malicious repository that requires authentication, the attacker can capture credentials for another Git remote. The attack is also heightened when cloning from repositories with submodules when using the `--recursive` clone option as the user is not able to inspect the submodule remote URLs beforehand. This issue has been patched in version 2.6.1 and all users are advised to upgrade. Users unable to upgrade should only interact with trusted remote repositories, and not clone with `--recursive` to allow inspection of any submodule URLs before cloning those submodules.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-50338?

2 open source packages ship an affected version, including git-credential-manager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git-credential-manager` | NuGet | All versions | 2.6.1 |
| `git-credential-manager` | NuGet | All versions | 2.6.1 |

## How do I fix CVE-2024-50338?

Upgrade git-credential-manager to 2.6.1 or later.

## Is CVE-2024-50338 being exploited?

There is no known exploitation of CVE-2024-50338 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50338 and fix it if it is affected.

What it is: CVE-2024-50338 is a high-severity vulnerability in git-ecosystem git-credential-manager, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-50338 in the wild and no public exploit code.

Affected packages and fixed versions:
- git-credential-manager (NuGet): affected all versions; fixed in 2.6.1
- git-credential-manager (NuGet): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50338/ (Markdown: https://insights.sbomify.com/CVE-2024-50338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50338
- OSV: https://osv.dev/vulnerability/CVE-2024-50338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50338/
Summaries are generated and may contain mistakes; the official description above is the record.
