# CVE-2024-50347: Laravel Reverb has Missing API Signature Verification

> Attackers can bypass API signature verification to broadcast messages or read channel statistics if the application ID is known.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2024
- **Updated:** 31 Oct 2024
- **Also known as:** GHSA-pfrr-xvrf-pxjx

## What is CVE-2024-50347?

CVE-2024-50347 is a medium-severity missing authorization vulnerability in laravel reverb, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Laravel Reverb provides a real-time WebSocket communication backend for Laravel applications. Prior to 1.4.0, there is an issue where verification signatures for requests sent to Reverb's Pusher-compatible API were not being verified. This API is used in scenarios such as broadcasting a message from a backend service or for obtaining statistical information (such as number of connections) about a given channel. This issue only affects the Pusher-compatible API endpoints and not the WebSocket connections themselves. In order to exploit this vulnerability, the application ID which, should never be exposed, would need to be known by an attacker. This vulnerability is fixed in 1.4.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-50347?

2 open source packages ship an affected version, including laravel/reverb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/reverb` | Packagist | All versions | 1.4.0 |
| `laravel/reverb` | Packagist | All versions | 1.4.0 |

## How do I fix CVE-2024-50347?

Upgrade laravel/reverb to 1.4.0 or later.

## Is CVE-2024-50347 being exploited?

There is no known exploitation of CVE-2024-50347 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50347 and fix it if it is affected.

What it is: CVE-2024-50347 is a medium-severity missing authorization vulnerability in laravel reverb, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-50347 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/reverb (Packagist): affected all versions; fixed in 1.4.0
- laravel/reverb (Packagist): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50347/ (Markdown: https://insights.sbomify.com/CVE-2024-50347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50347
- OSV: https://osv.dev/vulnerability/CVE-2024-50347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50347/
Summaries are generated and may contain mistakes; the official description above is the record.
