# CVE-2024-50350: LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/app/Http/Controllers/Table/EditPortsController.php

> Authenticated users can inject malicious JavaScript via the Port Group name, leading to session compromise when viewed by others.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2024
- **Updated:** 15 Nov 2024
- **Also known as:** GHSA-xh4g-c9p6-5jxg

## What is CVE-2024-50350?

CVE-2024-50350 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 15 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Port Settings" page allows authenticated users to inject arbitrary JavaScript through the "name" parameter when creating a new Port Group. This vulnerability results in the execution of malicious code when the "Port Settings" page is visited after the affected Port Group is added to a device, potentially compromising user sessions and allowing unauthorized actions. This vulnerability is fixed in 24.10.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-50350?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 24.10.0 |
| `librenms/librenms` | Packagist | All versions | 24.10.0 |

Products: Librenms Librenms.

## How do I fix CVE-2024-50350?

Upgrade librenms/librenms to 24.10.0 or later.

## Is CVE-2024-50350 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50350 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50350 and fix it if it is affected.

What it is: CVE-2024-50350 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 15 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50350 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0
- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50350/ (Markdown: https://insights.sbomify.com/CVE-2024-50350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50350
- OSV: https://osv.dev/vulnerability/CVE-2024-50350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50350/
Summaries are generated and may contain mistakes; the official description above is the record.
