# CVE-2024-50354: Out-of-memory during deserialization with crafted inputs

> Attackers can cause a denial of service by triggering out-of-memory errors during the deserialization of crafted Groth16 verification keys in the gnark library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2024
- **Updated:** 31 Oct 2024
- **Also known as:** GHSA-cph5-3pgr-c82g, GO-2024-3244

## What is CVE-2024-50354?

CVE-2024-50354 is a medium-severity denial of service vulnerability in Consensys gnark, published on 31 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

gnark is a fast zk-SNARK library that offers a high-level API to design circuits. In gnark 0.11.0 and earlier, deserialization of Groth16 verification keys allocate excessive memory, consuming a lot of resources and triggering a crash with the error fatal error: runtime: out of memory.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-50354?

3 open source packages ship an affected version, including github.com/consensys/gnark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/consensys/gnark` | Go | All versions | 0.11.1 |
| `github.com/consensys/gnark` | Go | All versions | 0.11.1 |
| `github.com/consensys/gnark` | Go | All versions | 0.12.0 |

Products: Consensys Gnark.

## How do I fix CVE-2024-50354?

Upgrade github.com/consensys/gnark to a fixed version for your release line: 0.11.1 or 0.12.0.

## Is CVE-2024-50354 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50354 exists.

## Other vulnerabilities in Consensys gnark

- [CVE-2025-57801](https://insights.sbomify.com/CVE-2025-57801/): gnark is vulnerable to signature malleability in EdDSA and ECDSA due to missing scalar checks (high 8.6)
- [CVE-2025-58157](https://insights.sbomify.com/CVE-2025-58157/): gnark affected by denial of service when computing scalar multiplication using fake-GLV algorithm (high 7.5)
- [CVE-2023-44378](https://insights.sbomify.com/CVE-2023-44378/): gnark vulnerable to unsoundness in variable comparison/non-unique binary decomposition (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50354 and fix it if it is affected.

What it is: CVE-2024-50354 is a medium-severity denial of service vulnerability in Consensys gnark, published on 31 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50354 exists.

Affected packages and fixed versions:
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.11.1
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.11.1
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50354/ (Markdown: https://insights.sbomify.com/CVE-2024-50354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50354
- OSV: https://osv.dev/vulnerability/CVE-2024-50354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50354/
Summaries are generated and may contain mistakes; the official description above is the record.
