{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50355 exists.","fix":"Upgrade librenms/librenms to 24.10.0 or later.","what":"CVE-2024-50355 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 15 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-50355 and fix it if it is affected.\n\nWhat it is: CVE-2024-50355 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 15 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50355 exists.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0\n- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-50355/ (Markdown: https://insights.sbomify.com/CVE-2024-50355/index.md)","id":"CVE-2024-50355","markdown":"https://insights.sbomify.com/CVE-2024-50355/index.md","name":"CVE-2024-50355","record":{"aliases":["GHSA-4m5r-w2rq-q54q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Network monitoring system","requires_auth":"high_privilege","summary":"An admin can inject persistent JavaScript via device display names, allowing attackers to execute scripts in other users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"librenms","vendor":"librenms"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. User with Admin role can edit the Display Name of a device, the application did not properly sanitize the user input in the device Display Name, if java script code is inside the name of the device Display Name, its can be trigger from different sources. This vulnerability is fixed in 24.10.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LibreNMS has a Persistent XSS from Insecure Input Sanitization Affects Multiple Endpoints","id":"CVE-2024-50355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"librenms:librenms","products":["librenms:librenms"],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Press has a potential 2FA bypass","id":"CVE-2024-50356"},"packages":[{"ecosystem":"Packagist","fixed":["24.10.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-4m5r-w2rq-q54q"},{"ecosystem":"Packagist","fixed":["24.10.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-4m5r-w2rq-q54q"}],"prev":{"headline":"Out-of-memory during deserialization with crafted inputs","id":"CVE-2024-50354"},"products":["librenms"],"published":"2024-11-15","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in librenms/librenms","id":"CVE-2023-4982","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":9.8,"headline":"Command injection in librenms","id":"CVE-2022-29712","kev_date_added":null,"published":"2022-05-31"},{"cvss_score":9.8,"headline":"Path traversal in librenms/librenms","id":"CVE-2021-44278","kev_date_added":null,"published":"2021-12-03"},{"cvss_score":9.8,"headline":"LibreNMS Information Disclosure","id":"CVE-2019-10665","kev_date_added":null,"published":"2019-09-09"},{"cvss_score":9.8,"headline":"LibreNMS arbitrary OS commands execution","id":"CVE-2018-20434","kev_date_added":null,"published":"2019-04-24"},{"cvss_score":9.3,"headline":"LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream","id":"CVE-2026-26988","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":9.2,"headline":"LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion","id":"CVE-2026-86426","kev_date_added":null,"published":"2026-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-15","vendors":["librenms"]},"summary":"An admin can inject persistent JavaScript via device display names, allowing attackers to execute scripts in other users' browsers.","url":"https://insights.sbomify.com/CVE-2024-50355/"}