# CVE-2024-50355: LibreNMS has a Persistent XSS from Insecure Input Sanitization Affects Multiple Endpoints

> An admin can inject persistent JavaScript via device display names, allowing attackers to execute scripts in other users' browsers.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2024
- **Updated:** 15 Nov 2024
- **Also known as:** GHSA-4m5r-w2rq-q54q

## What is CVE-2024-50355?

CVE-2024-50355 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 15 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. User with Admin role can edit the Display Name of a device, the application did not properly sanitize the user input in the device Display Name, if java script code is inside the name of the device Display Name, its can be trigger from different sources. This vulnerability is fixed in 24.10.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-50355?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 24.10.0 |
| `librenms/librenms` | Packagist | All versions | 24.10.0 |

Products: Librenms Librenms.

## How do I fix CVE-2024-50355?

Upgrade librenms/librenms to 24.10.0 or later.

## Is CVE-2024-50355 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50355 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50355 and fix it if it is affected.

What it is: CVE-2024-50355 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 15 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50355 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0
- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50355/ (Markdown: https://insights.sbomify.com/CVE-2024-50355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50355
- OSV: https://osv.dev/vulnerability/CVE-2024-50355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50355/
Summaries are generated and may contain mistakes; the official description above is the record.
