# CVE-2024-50378: Apache Airflow: Secrets not masked in UI when sensitive variables are set via Airflow cli

> Authenticated users with audit log access can view sensitive secrets stored unencrypted in logs when set via CLI, requiring an upgrade to fix.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Nov 2024
- **Updated:** 8 Nov 2024
- **Also known as:** BIT-airflow-2024-50378, ECHO-6aaf-e0c8-990a, GHSA-j857-2pwm-jjmm, PYSEC-2026-1134

## What is CVE-2024-50378?

CVE-2024-50378 is a medium-severity vulnerability in Apache Airflow, published on 8 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Airflow versions before 2.10.3 have a vulnerability that allows authenticated users with audit log access to see sensitive values in audit logs which they should not see. When sensitive variables were set via airflow CLI, values of those variables appeared in the audit log and were stored unencrypted in the Airflow database. While this risk is limited to users with audit log access, it is recommended to upgrade to Airflow 2.10.3 or a later version, which addresses this issue. Users who previously used the CLI to set secret variables should manually delete entries with those variables from the log table.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2024-50378?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.10.3 |
| `apache-airflow` | PyPI | All versions | 2.10.3 |
| `apache-airflow` | PyPI | All versions | 2.10.3 |
| `airflow` | Bitnami | All versions | 2.10.3 |

Products: Apache Airflow.

## How do I fix CVE-2024-50378?

Upgrade apache-airflow to 2.10.3 or later.

## Is CVE-2024-50378 being exploited?

There is no known exploitation of CVE-2024-50378 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50378 and fix it if it is affected.

What it is: CVE-2024-50378 is a medium-severity vulnerability in Apache Airflow, published on 8 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-50378 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.10.3
- apache-airflow (PyPI): affected all versions; fixed in 2.10.3
- apache-airflow (PyPI): affected all versions; fixed in 2.10.3
- airflow (Bitnami): affected all versions; fixed in 2.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50378/ (Markdown: https://insights.sbomify.com/CVE-2024-50378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50378
- OSV: https://osv.dev/vulnerability/CVE-2024-50378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50378/
Summaries are generated and may contain mistakes; the official description above is the record.
