# CVE-2024-50601: Cross-site scripting in n/a

> Attackers can execute arbitrary JavaScript via XSS in Axigen Mail Server, leading to session hijacking and data leakage.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 Nov 2024
- **Updated:** 12 Nov 2024
- **Also known as:** GHSA-5777-q3q8-vhh3

## What is CVE-2024-50601?

CVE-2024-50601 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Persistent and reflected XSS vulnerabilities in the themeMode cookie and _h URL parameter of Axigen Mail Server up to version 10.5.28 allow attackers to execute arbitrary Javascript. Exploitation could lead to session hijacking, data leakage, and further exploitation via a multi-stage attack. Fixed in versions 10.3.3.67, 10.4.42, and 10.5.29.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-50601?


## How do I fix CVE-2024-50601?

No fix has been published for CVE-2024-50601 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-50601 being exploited?

There is no known exploitation of CVE-2024-50601 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50601 and fix it if it is affected.

What it is: CVE-2024-50601 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-50601 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50601/ (Markdown: https://insights.sbomify.com/CVE-2024-50601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50601
- OSV: https://osv.dev/vulnerability/CVE-2024-50601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50601/
Summaries are generated and may contain mistakes; the official description above is the record.
