CVE-2024-50602 Denial of service in n/a

Medium 5.9 Published Updated

An attacker can cause a crash in the libexpat XML parsing library by triggering a specific parser state, leading to denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-50602?

CVE-2024-50602 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 27 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in libexpat before 2.6.4. There is a crash within the XML_ResumeParser function because XML_StopParser can stop/suspend an unstarted parser.

Weakness: CWE-754

Which versions are affected by CVE-2024-50602?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 12 products.

PackageAffectedFixed in
libpython BitnamiAll versions3.9.21, 3.10.16, 3.11.11, 3.12.8, 3.13.1
python BitnamiAll versions3.9.21, 3.10.16, 3.11.11, 3.12.8, 3.13.1
python-min BitnamiAll versions3.9.21, 3.10.16, 3.11.11, 3.12.8, 3.13.1
Linux distribution packages (37)
expat AlmaLinux:8All versions2.2.5-16.el8_10
expat-devel AlmaLinux:8All versions2.2.5-16.el8_10
expat AlmaLinux:9All versions2.5.0-3.el9_5.1
expat-devel AlmaLinux:9All versions2.5.0-3.el9_5.1
expat Red Hat:enterprise_linux:8::baseosAll versions0:2.2.5-16.el8_10
expat-debuginfo Red Hat:enterprise_linux:8::baseosAll versions0:2.2.5-16.el8_10
expat-debugsource Red Hat:enterprise_linux:8::baseosAll versions0:2.2.5-16.el8_10
expat-devel Red Hat:enterprise_linux:8::baseosAll versions0:2.2.5-16.el8_10
expat-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions0:2.5.0-3.el9_5.1
expat-debugsource Red Hat:enterprise_linux:9::appstreamAll versions0:2.5.0-3.el9_5.1
expat-devel Red Hat:enterprise_linux:9::appstreamAll versions0:2.5.0-3.el9_5.1
expat Red Hat:enterprise_linux:9::baseosAll versions0:2.5.0-3.el9_5.1
expat-debuginfo Red Hat:enterprise_linux:9::baseosAll versions0:2.5.0-3.el9_5.1
expat-debugsource Red Hat:enterprise_linux:9::baseosAll versions0:2.5.0-3.el9_5.1
expat-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:2.5.0-1.el9_2.2
expat-debugsource Red Hat:rhel_eus:9.2::appstreamAll versions0:2.5.0-1.el9_2.2
expat-devel Red Hat:rhel_eus:9.2::appstreamAll versions0:2.5.0-1.el9_2.2
expat Red Hat:rhel_eus:9.2::baseosAll versions0:2.5.0-1.el9_2.2
expat-debuginfo Red Hat:rhel_eus:9.2::baseosAll versions0:2.5.0-1.el9_2.2
expat-debugsource Red Hat:rhel_eus:9.2::baseosAll versions0:2.5.0-1.el9_2.2
expat-debuginfo Red Hat:rhel_eus:9.4::appstreamAll versions0:2.5.0-2.el9_4.2
expat-debugsource Red Hat:rhel_eus:9.4::appstreamAll versions0:2.5.0-2.el9_4.2
expat-devel Red Hat:rhel_eus:9.4::appstreamAll versions0:2.5.0-2.el9_4.2
expat Red Hat:rhel_eus:9.4::baseosAll versions0:2.5.0-2.el9_4.2
expat-debuginfo Red Hat:rhel_eus:9.4::baseosAll versions0:2.5.0-2.el9_4.2
expat-debugsource Red Hat:rhel_eus:9.4::baseosAll versions0:2.5.0-2.el9_4.2
expat Rocky Linux:8All versions0:2.2.5-16.el8_10
expat SUSE:Linux Enterprise Micro 5.1All versions2.2.5-150000.3.33.1
expat SUSE:Linux Enterprise Micro 5.2All versions2.2.5-150000.3.33.1
expat SUSE:Linux Enterprise Micro 5.3All versions2.4.4-150400.3.25.1
expat SUSE:Linux Enterprise Micro 5.4All versions2.4.4-150400.3.25.1
expat SUSE:Linux Enterprise Micro 5.5All versions2.4.4-150400.3.25.1
expat SUSE:Linux Enterprise Module for Basesystem 15 SP5All versions2.4.4-150400.3.25.1
expat SUSE:Linux Enterprise Module for Basesystem 15 SP6All versions2.4.4-150400.3.25.1
mozjs78 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5All versions78.15.0-150400.3.11.1
mozjs78 SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions78.15.0-150400.3.11.1
python3-wxPython SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions4.1.1-150400.10.1

Products include Debian Debian Linux, Libexpat Project Libexpat, Netapp Active Iq Unified Manager, Netapp H300s Firmware, Netapp H410c Firmware, Netapp H410s Firmware and 6 more.

How do I fix CVE-2024-50602?

Upgrade libpython to a fixed version for your release line: 3.9.21, 3.10.16, 3.11.11 or 3.12.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-50602 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50602 exists.

Public exploit code: 1 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2024-50602, ALSA-2024:9502, ALSA-2024:9541, AZL-51684, AZL-51735, BELL-CVE-2024-50602 and 46 more.

Is CVE-2024-50602 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free