# CVE-2024-50608: Null dereference in n/a

> Attackers can crash Fluent Bit by sending a zero-length packet to the Prometheus Remote Write plugin, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2025
- **Updated:** 19 Feb 2025
- **Also known as:** AZL-57074, AZL-57092, BIT-fluent-bit-2024-50608, GHSA-x9j4-33qm-hgjp

## What is CVE-2024-50608?

CVE-2024-50608 is a high-severity vulnerability in n/a, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Fluent Bit 3.1.9. When the Prometheus Remote Write input plugin is running and listening on an IP address and port, one can send a packet with Content-Length: 0 and it crashes the server. Improper handling of the case when Content-Length is 0 allows a user (with access to the endpoint) to perform a remote Denial of service attack. The crash happens because of a NULL pointer dereference when 0 (from the Content-Length) is passed to the function cfl_sds_len, which in turn tries to cast a NULL pointer into struct cfl_sds. This is related to process_payload_metrics_ng() at prom_rw_prot.c.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2024-50608?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 3.1.9 | 3.1.10 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2024-50608?

Upgrade fluent-bit to 3.1.10 or later.

## Is CVE-2024-50608 being exploited?

There is no known exploitation of CVE-2024-50608 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50608 and fix it if it is affected.

What it is: CVE-2024-50608 is a high-severity vulnerability in n/a, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-50608 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 3.1.9; fixed in 3.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50608/ (Markdown: https://insights.sbomify.com/CVE-2024-50608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50608
- OSV: https://osv.dev/vulnerability/CVE-2024-50608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50608/
Summaries are generated and may contain mistakes; the official description above is the record.
