# CVE-2024-50611: CycloneDX cdxgen may execute code contained within build-related files

> Attackers can execute arbitrary code by providing malicious build files to the CycloneDX cdxgen tool when scanning untrusted codebases.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2024
- **Updated:** 30 Oct 2024
- **Also known as:** GHSA-hxf3-vgpm-fv9p

## What is CVE-2024-50611?

CVE-2024-50611 is a high-severity code injection vulnerability in n/a, published on 27 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CycloneDX cdxgen through 10.10.7, when run against an untrusted codebase, may execute code contained within build-related files such as build.gradle.kts, a similar issue to CVE-2022-24441. cdxgen is used by, for example, OWASP dep-scan. NOTE: this has been characterized as a design limitation, rather than an implementation mistake.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-50611?

2 open source packages ship an affected version, including @cyclonedx/cdxgen.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cyclonedx/cdxgen` | npm | All versions | 11.1.7 |
| `@cyclonedx/cdxgen` | npm | All versions | 11.1.7 |

## How do I fix CVE-2024-50611?

Upgrade @cyclonedx/cdxgen to 11.1.7 or later.

## Is CVE-2024-50611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50611 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-50611 and fix it if it is affected.

What it is: CVE-2024-50611 is a high-severity code injection vulnerability in n/a, published on 27 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50611 exists.

Affected packages and fixed versions:
- @cyclonedx/cdxgen (npm): affected all versions; fixed in 11.1.7
- @cyclonedx/cdxgen (npm): affected all versions; fixed in 11.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-50611/ (Markdown: https://insights.sbomify.com/CVE-2024-50611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-50611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-50611
- OSV: https://osv.dev/vulnerability/CVE-2024-50611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-50611/
Summaries are generated and may contain mistakes; the official description above is the record.
