CVE-2024-50637 UnoPim Cross-site Scripting vulnerability

Medium 5.4 Published Updated

Attackers can inject malicious scripts via SVG uploads in the Create User function to steal cookies and potentially take over accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-50637?

CVE-2024-50637 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

UnoPim 0.1.3 and below is vulnerable to Cross Site Scripting (XSS) in the Create User function. This allows attackers to perform XSS via an SVG document, which can be used to steal cookies.

Weakness: CWE-79

Which versions are affected by CVE-2024-50637?

2 open source packages ship an affected version, including unopim/unopim. It affects 1 product.

PackageAffectedFixed in
unopim/unopim PackagistAll versions0.1.4
unopim/unopim PackagistAll versions0.1.4

Products include Webkul Unopim.

How do I fix CVE-2024-50637?

Upgrade unopim/unopim to 0.1.4 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-50637 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-50637 exists.

Sources

Also known as GHSA-hv6m-qj65-26q3.

Is CVE-2024-50637 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free