CVE-2024-5067 Exposure of Sensitive Information to an Unauthorized Actor in GitLab
Unauthorized group members with Developer roles can access sensitive project-level analytics settings via DOM exposure in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-5067?
CVE-2024-5067 is a medium-severity vulnerability in Gitlab Gitlab, published on 24 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in GitLab EE affecting all versions starting from 16.11 prior to 17.0.5, starting from 17.1 prior to 17.1.3, and starting from 17.2 prior to 17.2.1 where certain project-level analytics settings could be leaked in DOM to group members with Developer or higher roles.
Weakness: CWE-200
Which versions are affected by CVE-2024-5067?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.11.0 | 17.0.5, 17.1.3, 17.2.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-5067?
Upgrade gitlab to a fixed version for your release line: 17.0.5, 17.1.3 or 17.2.1.
Is CVE-2024-5067 being exploited?
There is no known exploitation of CVE-2024-5067 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-5067, GHSA-q2f3-hg8j-4wcc.