# CVE-2024-51092: LibreNMS has an Authenticated OS Command Injection

> Remote attackers can execute arbitrary code via OS command injection in LibreNMS network monitoring software.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-x645-6pf9-xwxw

## What is CVE-2024-51092?

CVE-2024-51092 is a critical command injection vulnerability in Librenms Librenms, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-51092?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 24.10.0 |
| `librenms/librenms` | Packagist | All versions | 24.10.0 |

Products: Librenms Librenms.

## How do I fix CVE-2024-51092?

Upgrade librenms/librenms to 24.10.0 or later.

## Is CVE-2024-51092 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51092 exists.

Public exploit code:

- LibreNMS Authenticated RCE (CVE-2024-51092) (metasploit)

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51092 and fix it if it is affected.

What it is: CVE-2024-51092 is a critical command injection vulnerability in Librenms Librenms, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51092 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0
- librenms/librenms (Packagist): affected all versions; fixed in 24.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51092/ (Markdown: https://insights.sbomify.com/CVE-2024-51092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51092
- OSV: https://osv.dev/vulnerability/CVE-2024-51092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51092/
Summaries are generated and may contain mistakes; the official description above is the record.
