CVE-2024-5126 Improper Access Control in lunary-ai/lunary

High 7.6 Published Updated

Unauthorized users can modify prompt details in Lunary AI due to missing access control checks in the versions.patch functionality.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-5126?

CVE-2024-5126 is a high-severity missing authorization vulnerability in Lunary Lunary, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.

Weakness: CWE-862

Which versions are affected by CVE-2024-5126?

It affects 1 product.

Products include Lunary Lunary.

How do I fix CVE-2024-5126?

No fix has been published for CVE-2024-5126 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-5126 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5126 exists.

All Lunary Lunary vulnerabilities

Sources

Also known as GHSA-9485-jr2m-q8rx.

Is CVE-2024-5126 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free