CVE-2024-5130 Incorrect Authorization in lunary-ai/lunary

High 7.5 Published Updated

Unauthenticated attackers can delete any dataset in Lunary AI due to missing authorization checks on the deletion endpoint.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-5130?

CVE-2024-5130 is a high-severity missing authorization vulnerability in Lunary Lunary, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An Incorrect Authorization vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, which allows unauthenticated users to delete any dataset. The vulnerability is due to the lack of proper authorization checks in the dataset deletion endpoint. Specifically, the endpoint does not verify if the provided project ID belongs to the current user, thereby allowing any dataset to be deleted without proper authentication. This issue was fixed in version 1.2.8.

Weakness: CWE-639, CWE-862

Which versions are affected by CVE-2024-5130?

It affects 1 product.

Products include Lunary Lunary.

How do I fix CVE-2024-5130?

No fix has been published for CVE-2024-5130 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-5130 being exploited?

There is no known exploitation of CVE-2024-5130 in the wild and no public exploit code.

All Lunary Lunary vulnerabilities

Sources

Also known as GHSA-f8mv-jphx-3r7g.

Is CVE-2024-5130 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free