{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-5130 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-5130 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-5130 is a high-severity missing authorization vulnerability in Lunary Lunary, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-5130 and fix it if it is affected.\n\nWhat it is: CVE-2024-5130 is a high-severity missing authorization vulnerability in Lunary Lunary, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-5130 in the wild and no public exploit code.\n\nAffected product: Lunary Lunary. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5130/ (Markdown: https://insights.sbomify.com/CVE-2024-5130/index.md)","id":"CVE-2024-5130","markdown":"https://insights.sbomify.com/CVE-2024-5130/index.md","name":"CVE-2024-5130","record":{"aliases":["GHSA-f8mv-jphx-3r7g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Lunary AI platform","requires_auth":"none","summary":"Unauthenticated attackers can delete any dataset in Lunary AI due to missing authorization checks on the deletion endpoint.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"lunary","vendor":"lunary"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-862","name":"Missing Authorization"}],"description":"An Incorrect Authorization vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, which allows unauthenticated users to delete any dataset. The vulnerability is due to the lack of proper authorization checks in the dataset deletion endpoint. Specifically, the endpoint does not verify if the provided project ID belongs to the current user, thereby allowing any dataset to be deleted without proper authentication. This issue was fixed in version 1.2.8.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-5130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"lunary:lunary","products":["lunary:lunary"],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Improper Access Control in lunary-ai/lunary","id":"CVE-2024-5131"},"packages":[],"prev":{"headline":"Privilege Escalation Vulnerability in lunary-ai/lunary","id":"CVE-2024-5129"},"products":["lunary-ai/lunary"],"published":"2024-06-06","related":[{"cvss_score":9.8,"headline":"Improper Access Control in lunary-ai/lunary","id":"CVE-2024-8999","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"Improper Authorization in lunary-ai/lunary","id":"CVE-2024-9095","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"SQL Injection in lunary-ai/lunary","id":"CVE-2024-7456","kev_date_added":null,"published":"2024-11-01"},{"cvss_score":9.8,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-4146","kev_date_added":null,"published":"2024-06-08"},{"cvss_score":9.6,"headline":"Account Hijacking via Password Reset Token Leak in lunary-ai/lunary","id":"CVE-2024-5386","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.6,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-3379","kev_date_added":null,"published":"2024-11-14"},{"cvss_score":9.4,"headline":"IDOR Vulnerability in lunary-ai/lunary","id":"CVE-2024-5128","kev_date_added":null,"published":"2024-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["lunary-ai"]},"summary":"Unauthenticated attackers can delete any dataset in Lunary AI due to missing authorization checks on the deletion endpoint.","url":"https://insights.sbomify.com/CVE-2024-5130/"}