CVE-2024-5131 Improper Access Control in lunary-ai/lunary

High 7.5 Published Updated

Unauthorized users can view any prompts in any projects by supplying a specific prompt ID to an endpoint lacking ownership verification.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-5131?

CVE-2024-5131 is a high-severity missing authorization vulnerability in Lunary Lunary, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.

Weakness: CWE-639

Which versions are affected by CVE-2024-5131?

It affects 1 product.

Products include Lunary Lunary.

How do I fix CVE-2024-5131?

No fix has been published for CVE-2024-5131 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-5131 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5131 exists.

All Lunary Lunary vulnerabilities

Sources

Also known as GHSA-wm2w-xpgv-w6v4.

Is CVE-2024-5131 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free