# CVE-2024-51408: Server-side request forgery in n/a

> Attackers can exploit Server-Side Request Forgery in AppSmith to retrieve AWS metadata credentials via malicious data source requests.

- **Severity:** High 8.5 (`CVSS:3.1/AC:H/AV:N/A:H/C:H/I:H/PR:L/S:C/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2024
- **Updated:** 5 Nov 2024
- **Also known as:** BIT-appsmith-2024-51408, GHSA-94hw-32gv-86pf

## What is CVE-2024-51408?

CVE-2024-51408 is a high-severity server-side request forgery vulnerability in n/a, published on 4 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

AppSmith Community 1.8.3 before 1.46 allows SSRF via New DataSource for application/json requests to 169.254.169.254 to retrieve AWS metadata credentials.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-51408?

1 open source package ship an affected version, including appsmith. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `appsmith` | Bitnami | From 1.8.3 | 1.46.0 |

Products: Appsmith Appsmith.

## How do I fix CVE-2024-51408?

Upgrade appsmith to 1.46.0 or later.

## Is CVE-2024-51408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51408 exists.

## Other vulnerabilities in n/a

- [CVE-2026-55454](https://insights.sbomify.com/CVE-2026-55454/): Appsmith: Caddy admin API exposed without authentication (critical 9.9)
- [CVE-2024-55964](https://insights.sbomify.com/CVE-2024-55964/): Code injection in n/a (critical 9.8)
- [CVE-2026-22794](https://insights.sbomify.com/CVE-2026-22794/): Account Takeover Vulnerability in Appsmith (critical 9.7)
- [CVE-2026-24042](https://insights.sbomify.com/CVE-2026-24042/): Appsmith public apps can execute unpublished actions (viewMode confusion) (critical 9.4)
- [CVE-2026-30862](https://insights.sbomify.com/CVE-2026-30862/): Critical Stored XSS & Privilege Escalation in Appsmith (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51408 and fix it if it is affected.

What it is: CVE-2024-51408 is a high-severity server-side request forgery vulnerability in n/a, published on 4 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51408 exists.

Affected packages and fixed versions:
- appsmith (Bitnami): affected from 1.8.3; fixed in 1.46.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51408/ (Markdown: https://insights.sbomify.com/CVE-2024-51408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51408
- OSV: https://osv.dev/vulnerability/CVE-2024-51408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51408/
Summaries are generated and may contain mistakes; the official description above is the record.
